View Single Post
Old 03-11-04, 11:57 PM   #1
mbekkail
Registered User
 
Join Date: Feb 2004
Posts: 2
Unhappy NVIDIA NIC driver installation problems in Suse 9.0

I have M7NCG mobo by Biostar with onboard NVIDIA nForce MCP Networking Adapter and just installed Suse 9.0 as a second OS (wxppro is 1st). Now, I downloaded the NIC driver of the NVIDIA website and followed installation instructions. Here is the log of the RPMBUILD command:

mbekkali@linux:~> su
Password:
linux:/home/mbekkali # cd Linux
linux:/home/mbekkali/Linux # dir
total 110652
drwxr-xr-x 2 mbekkali users 288 2004-02-24 15:19 .
drwxr-xr-x 24 mbekkali users 1360 2004-02-24 15:54 ..
-r-xr-xr-x 1 root root 92517 2004-02-24 10:45 NVIDIA_nforce-1.0-0261.src.rpm
-r-xr-xr-x 1 mbekkali users 57486 2004-02-06 08:19 NVIDIA_nforce-1.0-0261.suse90.i586.rpm
-r-xr-xr-x 1 root root 378880 2003-05-06 12:39 NVIDIA_nforce-1.0-0261.tar[1]
-r-xr-xr-x 1 root root 87301 2004-02-24 10:44 NVIDIA_nforce-1.0-0261.tar.gz
-r-xr-xr-x 1 root root 112567600 2004-02-07 11:57 Suse Linux Wine Rack.rar
linux:/home/mbekkali/Linux # rpmbuild --rebuild NVIDIA_nforce-1.0-0261.src.rpm
Installing NVIDIA_nforce-1.0-0261.src.rpm
warning: user buildmeister does not exist - using root
warning: group adm does not exist - using root
warning: user buildmeister does not exist - using root
warning: group adm does not exist - using root
warning: user buildmeister does not exist - using root
warning: group adm does not exist - using root
warning: user buildmeister does not exist - using root
warning: group adm does not exist - using root
warning: user buildmeister does not exist - using root
warning: group adm does not exist - using root
Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.16528
+ umask 022
+ cd /usr/src/packages/BUILD
+ echo '---- Copying Sources ----'
---- Copying Sources ----
+ cd /usr/src/packages/BUILD
+ rm -rf nforce
+ /usr/bin/gzip -dc /usr/src/packages/SOURCES/nvnet.tgz
+ tar -xvvf -
drwxr-xr-x buildmeister/adm 0 2003-05-06 12:36:14 nforce/
drwxr-xr-x buildmeister/adm 0 2003-05-06 12:39:37 nforce/nvnet/
-r--r--r-- buildmeister/adm 16904 2003-05-06 12:39:37 nforce/nvnet/adapter.h
-r--r--r-- buildmeister/adm 794 2003-05-06 12:39:37 nforce/nvnet/basetype.h
-r--r--r-- buildmeister/adm 6752 2003-05-06 12:39:37 nforce/nvnet/nvnet.h
-r--r--r-- buildmeister/adm 4437 2003-05-06 12:39:37 nforce/nvnet/os.h
-r--r--r-- buildmeister/adm 4749 2003-05-06 12:39:37 nforce/nvnet/phy.h
-r--r--r-- buildmeister/adm 37870 2003-05-06 12:39:37 nforce/nvnet/nvnet.c
-rw-r--r-- buildmeister/adm 21504 2003-05-06 12:39:37 nforce/nvnet/nvnetlib.o
-r--r--r-- buildmeister/adm 3088 2003-05-06 12:39:37 nforce/nvnet/Makefile
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd nforce
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chown -Rhf root .
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chgrp -Rhf root .
+ /bin/chmod -Rf a+rX,g-w,o-w .
+ cd /usr/src/packages/BUILD
+ /usr/bin/gzip -dc /usr/src/packages/SOURCES/nvaudio.tgz
+ tar -xvvf -
drwxr-xr-x buildmeister/adm 0 2003-05-06 12:39:38 nforce/
drwxr-xr-x buildmeister/adm 0 2003-05-06 12:39:38 nforce/nvaudio/
-r--r--r-- buildmeister/adm 2522 2003-05-06 12:39:38 nforce/nvaudio/Makefile
-r--r--r-- buildmeister/adm 58241 2003-05-06 12:39:38 nforce/nvaudio/nvcrush.c
-r--r--r-- buildmeister/adm 32174 2003-05-06 12:39:38 nforce/nvaudio/nvhw.c
-r--r--r-- buildmeister/adm 33857 2003-05-06 12:39:38 nforce/nvaudio/nvmain.c
-r--r--r-- buildmeister/adm 8314 2003-05-06 12:39:38 nforce/nvaudio/nvrec.c
-r--r--r-- buildmeister/adm 26382 2003-05-06 12:39:38 nforce/nvaudio/nvspdif.c
-r--r--r-- buildmeister/adm 14709 2003-05-06 12:39:38 nforce/nvaudio/nvwavout.c
-r--r--r-- buildmeister/adm 4546 2003-05-06 12:39:38 nforce/nvaudio/chaninfo.h
-r--r--r-- buildmeister/adm 5065 2003-05-06 12:39:38 nforce/nvaudio/nvhw.h
-r--r--r-- buildmeister/adm 1570 2003-05-06 12:39:38 nforce/nvaudio/nvioctl.h
-r--r--r-- buildmeister/adm 1392 2003-05-06 12:39:38 nforce/nvaudio/nvrec.h
-r--r--r-- buildmeister/adm 1618 2003-05-06 12:39:38 nforce/nvaudio/nvspdif.h
-r--r--r-- buildmeister/adm 1499 2003-05-06 12:39:38 nforce/nvaudio/nvwavout.h
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd nforce
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chown -Rhf root .
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chgrp -Rhf root .
+ /bin/chmod -Rf a+rX,g-w,o-w .
+ cd /usr/src/packages/BUILD
+ /usr/bin/gzip -dc /usr/src/packages/SOURCES/nvmaster.tgz
+ tar -xvvf -
drwxr-xr-x buildmeister/adm 0 2003-05-06 12:39:36 nforce/
-r--r--r-- buildmeister/adm 1091 2003-05-06 12:39:36 nforce/Makefile
-r--r--r-- buildmeister/adm 5404 2003-05-06 12:39:36 nforce/NVLicense.txt
-r--r--r-- buildmeister/adm 18007 2003-05-06 12:39:36 nforce/GNULicense.txt
-r--r--r-- buildmeister/adm 23612 2003-05-06 12:39:36 nforce/ReleaseNotes.html
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd nforce
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chown -Rhf root .
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chgrp -Rhf root .
+ /bin/chmod -Rf a+rX,g-w,o-w .
+ cd /usr/src/packages/BUILD
+ /usr/bin/gzip -dc /usr/src/packages/SOURCES/nvgart.tgz
+ tar -xvvf -
drwxr-xr-x buildmeister/adm 0 2003-05-06 12:39:38 nforce/
drwxr-xr-x buildmeister/adm 0 2003-05-06 12:39:38 nforce/nvgart/
-r--r--r-- buildmeister/adm 590 2003-05-06 12:39:38 nforce/nvgart/Makefile
-r--r--r-- buildmeister/adm 1231 2003-05-06 12:39:38 nforce/nvgart/README
-r--r--r-- buildmeister/adm 14033 2003-05-06 12:39:38 nforce/nvgart/linux-2.4.20-agpgart.diff
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd nforce
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chown -Rhf root .
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chgrp -Rhf root .
+ /bin/chmod -Rf a+rX,g-w,o-w .
+ exit 0
Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.16528
+ umask 022
+ cd /usr/src/packages/BUILD
+ cd nforce
+ echo '---- Building Drivers ----'
---- Building Drivers ----
+ make
/var/tmp/rpm-tmp.16528: line 24: make: command not found
error: Bad exit status from /var/tmp/rpm-tmp.16528 (%build)


RPM build errors:
user buildmeister does not exist - using root
group adm does not exist - using root
user buildmeister does not exist - using root
group adm does not exist - using root
user buildmeister does not exist - using root
group adm does not exist - using root
user buildmeister does not exist - using root
group adm does not exist - using root
user buildmeister does not exist - using root
group adm does not exist - using root
Bad exit status from /var/tmp/rpm-tmp.16528 (%build)
linux:/home/mbekkali/Linux #

Apparently, the driver is not installed since the installation generates the error messages. The problem is that I cannot find how to handle such errors since troubleshooting section of readme accompanying the driver does not have such.

IFCONFIG gives me

linux:/home/mbekkali # ifconfig
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:115 errors:0 dropped:0 overruns:0 frame:0
TX packets:115 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:7683 (7.5 Kb) TX bytes:7683 (7.5 Kb)

linux:/home/mbekkali # ifconfig eth0 up
eth0: unknown interface: No such device
linux:/home/mbekkali # ifconfig eth0
eth0: error fetching interface information: Device not found
linux:/home/mbekkali #
linux:/home/mbekkali #

I emailed several times to NVIDIA support but have not got any replies. I tried to install tar.gz file and src.rpm but get a message that the rpm is already installed (?).

Please help me. I don't want the saying "Linux works 98% of the time, but it is 2% that kill" come true. I've been posting on various forums but have not got any solution yet. It's been over 2 month now.
mbekkail is offline   Reply With Quote