Thread: AGP Mode 4
View Single Post
Old 10-19-02, 08:09 AM   #5
Registered User
Join Date: Sep 2002
Posts: 2,262

options NVdriver NVreg_Enable4x=1
I assume you mean NVreg_EnableVia4x, right? There is no such option NVreg_Enable4x. The reason is that by default, the driver picks the best AGP rate that both the card and motherboard can handle, and then when nVidia sees a lot of problems with certain e.g. chipsets (like Via's), they drop the AGP rate back down for those chipsets. Then they put options like this in the module to disable the rate-drop behavior, so if your specific chipset isn't buggy (like my KT333 isn't), you can enable those options to get the highest supported rate back.

Since you have an i815, none of this applies to you since there aren't really many problems with that chipset -- at least, that's what I gather since there aren't any options to turn it off, and on my i815 (my router/firewall), 4x mode is on as well (but that's a GF2 GTS, so maybe it's the card...)

Anyway, you can check what modes different pieces of the puzzle support by looking at /proc/driver/nvidia/agp/card and /proc/driver/nvidia/agp/host-bridge. For example, mine, on my i815, look like this (type in the stuff in bold, not the rest of it, to find out on your machine ):

[root@3dguios root]# cat /proc/driver/nvidia/agp/card
Fast Writes:       Supported
SBA:               Not Supported
AGP Rates:         4x 2x 1x
Registers:         <this doesn't matter>
[root@3dguios root]# 
[root@3dguios root]# cat /proc/driver/nvidia/agp/host-bridge
Host Bridge:       Intel 815
Fast Writes:       Not Supported
SBA:               Supported
AGP Rates:         4x 2x 1x
Registers:         <again, doesn't matter>
So if I were to try to enable both SBA and FW, for example, neither one would work (which is ... odd, since I had SBA working before... oh well, I don't use that machine for graphics anyway anymore, so it's not a huge deal), since the card doesn't support one, and the host bridge doesn't support the other. I would get AGP 4x though, because that's the highest rate that they both support.

Try checking into those files (host-bridge and card, that is), and see if you can figure out which one isn't letting you get higher AGP rates.
Registered Linux User #219692
bwkaz is offline   Reply With Quote