View Single Post
Old 04-15-04, 10:58 PM   #1
FireFerum
Always Need Help
 
Join Date: Apr 2004
Location: Lawrenceville, GA
Posts: 8
Send a message via ICQ to FireFerum
Unhappy XFree86-4 (Mdk 10) crashes with driver 5336

I tried to install the new drivers as I am trying to be able to run Counter-Strike on WineX and I need OpenGL. So, I downloaded the drivers, followed the instructions to install, everything was OK, I loaded into XFree86-4 which is by default what comes up when I log in and edited the XF86Config-4 file just by switching nv to nvidia. Here is the file:
Code:
# File generated by XFdrake.

# **********************************************************************
# Refer to the XF86Config man page for details about the format of
# this file.
# **********************************************************************

Section "Files"
    # Multiple FontPath entries are allowed (they are concatenated together)
    # By default, Mandrake 6.0 and later now use a font server independent of
    # the X server to render fonts.
    FontPath "unix/:-1"
EndSection

Section "ServerFlags"
    #DontZap # disable <Crtl><Alt><BS> (server abort)
    AllowMouseOpenFail # allows the server to start up even if the mouse doesn't work
    #DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
EndSection

Section "Module"
    Load "dbe" # Double-Buffering Extension
    Load "v4l" # Video for Linux
    Load "extmod"
    Load "type1"
    Load "freetype"
    Load "glx" # 3D layer
EndSection

Section "InputDevice"
    Identifier "Keyboard1"
    Driver "Keyboard"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "en_US"
    Option "XkbOptions" ""
EndSection

Section "InputDevice"
    Identifier "Mouse1"
    Driver "mouse"
    Option "Protocol" "ExplorerPS/2"
    Option "Device" "/dev/mouse"
    Option "ZAxisMapping" "6 7"
EndSection

Section "Monitor"
    Identifier "monitor1"
    VendorName "Plug'n Play"
    ModelName "Dell D1226H"
    HorizSync 30-95
    VertRefresh 50-160
    
    # Sony Vaio C1(X,XS,VE,VN)?
    # 1024x480 @ 85.6 Hz, 48 kHz hsync
    ModeLine "1024x480"    65.00 1024 1032 1176 1344   480  488  494  563 -hsync -vsync
    
    # TV fullscreen mode or DVD fullscreen output.
    # 768x576 @ 79 Hz, 50 kHz hsync
    ModeLine "768x576"     50.00  768  832  846 1000   576  590  595  630
    
    # 768x576 @ 100 Hz, 61.6 kHz hsync
    ModeLine "768x576"     63.07  768  800  960 1024   576  578  590  616
EndSection

Section "Device"
    Identifier "device1"
    VendorName "nVidia Corporation"
    BoardName "NVIDIA GeForce2 DDR (generic)"
    Driver "nvidia"
    Option "DPMS"
EndSection

Section "Screen"
    Identifier "screen1"
    Device "device1"
    Monitor "monitor1"
    DefaultColorDepth 24
    
    Subsection "Display"
        Depth 8
        Virtual 1024 768
    EndSubsection
    
    Subsection "Display"
        Depth 15
        Virtual 1024 768
    EndSubsection
    
    Subsection "Display"
        Depth 16
        Virtual 1024 768
    EndSubsection
    
    Subsection "Display"
        Depth 24
        Virtual 1024 768
    EndSubsection
EndSection

Section "ServerLayout"
    Identifier "layout1"
    InputDevice "Keyboard1" "CoreKeyboard"
    InputDevice "Mouse1" "CorePointer"
    Screen "screen1"
EndSection
So, once I did a reboot and all XFree86-4 did not come up and Linux went to non visual mode for me wonder what went wrong. I have the XFree86-4 log file too which I will list below (last part of it) because I am not too good with linux. I have been trying to get it to be in tip top shape for about a week now non-stop, mostly to get Counter-Strike to play on there (tried VMware and wine, and more but that's a different story). Back to the topic, I tried to install again with the same type of results so please somebody help me! Here is that log file and I am sorry if it makes the thread too long. I am new to this forum so I don't know all the rules yet.
Code:
(II) Module mouse: vendor="The XFree86 Project"
	compiled for 4.3.0.1, module version = 1.0.0
	Module class: XFree86 XInput Driver
	ABI class: XFree86 XInput driver, version 0.4
(II) v4l driver for Video4Linux
(II) NVIDIA XFree86 Driver  1.0-5336  Wed Jan 14 18:30:46 PST 2004
(II) NVIDIA Unified Driver for all NVIDIA GPUs
(II) Primary Device is: PCI 00:0a:0
(--) Assigning device section with no busID to primary device
(--) Chipset NVIDIA GPU found
(II) resource ranges after xf86ClaimFixedResources() call:
	[0] -1	0	0xffe00000 - 0xffffffff (0x200000) MX[b](B)
	[1] -1	0	0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
	[2] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[b]
	[3] -1	0	0x000c0000 - 0x000effff (0x30000) MX[b]
	[4] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[b]
	[5] -1	0	0xe2003000 - 0xe20030ff (0x100) MX[b]
	[6] -1	0	0xe2002000 - 0xe2002fff (0x1000) MX[b]
	[7] -1	0	0xe2001000 - 0xe2001fff (0x1000) MX[b]
	[8] -1	0	0xe2000000 - 0xe2000fff (0x1000) MX[b]
	[9] -1	0	0xd0000000 - 0xcfffffff (0x0) MX[b]O
	[10] -1	0	0xd8000000 - 0xdfffffff (0x8000000) MX[b](B)
	[11] -1	0	0xe0000000 - 0xe0ffffff (0x1000000) MX[b](B)
	[12] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[b]
	[13] -1	0	0x00000000 - 0x000000ff (0x100) IX[b]
	[14] -1	0	0x0000e800 - 0x0000e8ff (0x100) IX[b]
	[15] -1	0	0x0000e400 - 0x0000e47f (0x80) IX[b]
	[16] -1	0	0x0000e000 - 0x0000e0ff (0x100) IX[b]
	[17] -1	0	0x00004000 - 0x0000400f (0x10) IX[b]
	[18] -1	0	0x000010c0 - 0x000010df (0x20) IX[b]
(II) resource ranges after probing:
	[0] -1	0	0xffe00000 - 0xffffffff (0x200000) MX[b](B)
	[1] -1	0	0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
	[2] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[b]
	[3] -1	0	0x000c0000 - 0x000effff (0x30000) MX[b]
	[4] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[b]
	[5] -1	0	0xe2003000 - 0xe20030ff (0x100) MX[b]
	[6] -1	0	0xe2002000 - 0xe2002fff (0x1000) MX[b]
	[7] -1	0	0xe2001000 - 0xe2001fff (0x1000) MX[b]
	[8] -1	0	0xe2000000 - 0xe2000fff (0x1000) MX[b]
	[9] -1	0	0xd0000000 - 0xcfffffff (0x0) MX[b]O
	[10] -1	0	0xd8000000 - 0xdfffffff (0x8000000) MX[b](B)
	[11] -1	0	0xe0000000 - 0xe0ffffff (0x1000000) MX[b](B)
	[12] 0	0	0x000a0000 - 0x000affff (0x10000) MS[b]
	[13] 0	0	0x000b0000 - 0x000b7fff (0x8000) MS[b]
	[14] 0	0	0x000b8000 - 0x000bffff (0x8000) MS[b]
	[15] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[b]
	[16] -1	0	0x00000000 - 0x000000ff (0x100) IX[b]
	[17] -1	0	0x0000e800 - 0x0000e8ff (0x100) IX[b]
	[18] -1	0	0x0000e400 - 0x0000e47f (0x80) IX[b]
	[19] -1	0	0x0000e000 - 0x0000e0ff (0x100) IX[b]
	[20] -1	0	0x00004000 - 0x0000400f (0x10) IX[b]
	[21] -1	0	0x000010c0 - 0x000010df (0x20) IX[b]
	[22] 0	0	0x000003b0 - 0x000003bb (0xc) IS[b]
	[23] 0	0	0x000003c0 - 0x000003df (0x20) IS[b]
(II) Setting vga for screen 0.
(II) Loading sub module "vgahw"
(II) LoadModule: "vgahw"
(II) Loading /usr/X11R6/lib/modules/libvgahw.a
(II) Module vgahw: vendor="The XFree86 Project"
	compiled for 4.3.0.1, module version = 0.1.0
	ABI class: XFree86 Video Driver, version 0.6
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(--) NVIDIA(0): Linear framebuffer at 0xD8000000
(--) NVIDIA(0): MMIO registers at 0xE0000000
(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module!
(EE) NVIDIA(0):  *** Aborting ***
(II) UnloadModule: "nvidia"
(II) UnloadModule: "vgahw"
(II) Unloading /usr/X11R6/lib/modules/libvgahw.a
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
This can be found in the log file "/var/log/XFree86.0.log".
Please report problems to xfree86@xfree86.org.
Oh, and I am running the following:

Mandrake 10.0 (kernel 2.6.3-4)
GeForce2 MX (64MB)
AMD XP2500+
512 MB PC3200 RAM

as for the rest I doubt they matter but here you go:
Winex3.3.1
FireFerum is offline   Reply With Quote