View Single Post
Old 10-22-02, 03:50 AM   #14
arise
Registered User
 
Join Date: Oct 2002
Location: Europe
Posts: 93
Default

Yes I found in the meantime a possible solution, however I cannot try it until I get home tonight:

http://www.dtek.chalmers.se/groups/dvd/faq.shtml

==============================================

31. Playback is choppy. What can I do?

NOTE RedHat 8.0:
In all their wisdom, the people at redhat decided to turn off DMA for CD and DVD devices
in an even "more reliable" way than before.
To be able to turn on DMA _at all_ you have to add the following line in /etc/modules.conf :
options ide-cd dma=1
You can also download and compile your own kernel (not a redhat kernel) to be able to turn on dma.
Keep reading to see what else you need to do to turn on dma.
end NOTE RedHat 8.0

Check with hdparm (hdparm -d <device name>) if you have enabled DMA on the DVD drive.
hdparm -d 1 <device name> to turn dma on. The link above will explain n more detail.
If you have enabled DMA and it still is choppy and you have an nVidia card see also FAQ 38.
If you have enabled DMA and it still is choppy or dma keeps turning off and you have a VIA chipset (mostly amd users) try with hdparm -d 1 -X34 <device name> to use another dma mode.
NOTE: In redhat7.3 DMA is default OFF for cd/dvd drives
The official way to turn change this is to create a file named /etc/sysconfig/harddiskhdc (the hdc at the end should be replaced with the device name for you DVD). Use the contents of /etc/sysconfig/harddisks as a template. The rc.sysinit script will apply the contents of /etc/sysconfig/harddisks to hard drives only, but if it sees a file for a specific drive, it will apply it to that drive even if it is not a hard drive.
NOTE: If you run debian, make sure you use the ogle-mmx package if you are running on x86.
==============================================
arise is offline   Reply With Quote