Thread: 4 kb stacks
View Single Post
Old 04-19-04, 12:24 PM   #7
LordMorgul
Electrical Engineer
 
LordMorgul's Avatar
 
Join Date: Dec 2002
Location: San Luis Obispo, CA
Posts: 872
Default Re: 4 kb stacks

Quote:
Originally Posted by pzgren
CONFIG_REGPARM=y
<snip>
Pull the source and disable it, 10 min and you can play UT all night long!
Not quite so, removal of REGPARM does not correct the problem for all users, myself included -- and beside that Zander's patch to 5341 should workaround REGPARM to leave it enabled.

I am intrigued by your system working with 4KSTACKS as it has never worked for one of my builds (and I have built somewhere around 24 separate versions / configs since 4KSTACKS showed up in FC2 Rawhide kernels). REGPARM has worked (with said patch). Clearly this is not a cut and dry situation on either side of these options. Honestly, I would like to understand more.

What chipsets do you have, what video card / bios?

$-> cat /proc/driver/nvidia/cards/0
Model: GeForce4 Ti 4400
IRQ: 7
Video BIOS: 04.25.00.22.50
Card Type: AGP

01:00.0 VGA compatible controller: nVidia Corporation NV25 [GeForce4 Ti 4400] (rev a2) (prog-if 00 [VGA])
Subsystem: VISIONTEK: Unknown device 003c
Flags: bus master, VGA palette snoop, 66Mhz, medium devsel, latency 248, IRQ 7

00:01.0 PCI bridge: Intel Corp. 82850 850 (Tehama) Chipset AGP Bridge (rev 04) (prog-if 00 [Normal decode])
Flags: bus master, 66Mhz, fast devsel, latency 64
Bus: primary=00, secondary=01, subordinate=01, sec-latency=64
__________________
"..the triumph of evil is for good men to do nothing." (Edmond Burke)
nVIDIA video driver RPMs for Fedora :: see yum repo at livna.org.
LordMorgul is offline   Reply With Quote