View Single Post
Old 04-20-04, 11:43 PM   #18
zexicco
Registered User
 
Join Date: Apr 2004
Posts: 1
Default Re: NVIDIA-5336 + latest 2.6 kernel problems

If message "Unable to determine system version" occurred while building nvidia driver, it means the header file "include/linux/version.h" couldn't be found. If you build kernel 2.6.x within build directory as the steps in kernel source README described, you have to copy "version.h" from build directory to kernel source directory manually.
Furthermore, the gcc's version that is used to compile nvidia driver must be the same gcc that is used to compile kernel. Therefore, there maybe a need to compile nvidia driver manually.
Well, suppose the kernel is compiled with gcc-2.95.3, then run the commands below:
#sh NVIDIA-Linux-x86-1.0-5336-pkg1.run --extract-only
#cd NVIDIA-Linux-x86-1.0-5336\nv
#CC=/usr/bin/gcc-2.95.3 make && make install
zexicco is offline   Reply With Quote