View Single Post
Old 05-06-04, 05:31 PM   #1
SenorSnor
Registered User
 
Join Date: May 2004
Posts: 25
Default Screen too wide with TwinView

I'm using a GeForce 440 MX, XFree86 4.4, NVidia drivers 5336 and Slackware current. I set up TwinView with my TV and what I want is that I work normally on my monitor (1024x768) and occasionally switch to another mode where my TV will be activated as well.

This works but with one problem: when I'm not using the TV, the screen size of my monitor gets wider then 1024x768. When I move my mouse beyond the right edge of the screen, the whole screen scrolls to the left. I guess the size of the extension to the right is about half a screen.

When I switch modes so my TV gets activated as well, the size of both screens is right. How can I fix this so in the mode without TV, the size of the desktop fits my screen?

Relevent section from XFree86Config:

Section "Device"
Identifier "** NVIDIA (generic) [nvidia]"
Driver "nvidia"
VideoRam 65536
# Insert Clocks lines here if appropriate
vendorname ""
boardname ""

Option "TwinView" "On"
Option "SecondMonitorHorizSync" "30-50"
Option "SecondMonitorVertSync" "60"
Option "MetaModes" "1024x768, NULL; 1024x768, 640x480"
Option "TwinViewOrientation" "RightOf"
EndSection

Section "Screen"
Identifier "Screen 1"
Device "** NVIDIA (generic) [nvidia]"
Monitor "My Monitor"
DefaultDepth 24

Option "TVStandard" "PAL-B"
Option "TVOutFormat" "COMPOSITE"

Subsection "Display"
Depth 24
Modes "1024x768/70Hz" "1024x768" "800x600" "640x480"
ViewPort 0 0
Virtual 0 0
EndSubsection
EndSection
SenorSnor is offline   Reply With Quote