View Single Post
Old 05-09-04, 03:37 PM   #5
hppnq
Registered User
 
Join Date: Apr 2004
Location: Dutch
Posts: 113
Default Re: Getting GLX to work ...

In /usr/X11R6/lib/modules/extensions, check whether the Nvidia GLX extension is there;
it most probably has the version 1.0.5336 appended to it, and there should be a symbolic link pointing to it. So, you should have something like

lrwxrwxrwx 1 root root 18 Apr 16 01:08 libglx.so -> libglx.so.1.0.5336
-rwxr-xr-x 1 root root 647268 Apr 16 01:08 libglx.so.1.0.5336

The extension you are loading is called libglx.a, that's the one provided by Xfree86. You can remove it or move it to another directory.

If you only have this libglx.a, something must have gone wrong while installing nvidia-glx. Try installing the Nvidia driver the Nvidia way instead of the Debian way then. ;-)

Otherwise, removing the file libglx.a will most probably solve your problem.

(There is no need really to turn on more debugging, the problem is definitely loading the wrong extension.)
hppnq is offline   Reply With Quote