View Single Post
Old 05-09-04, 04:37 PM   #4
khalid357
Registered User
 
Join Date: May 2004
Posts: 13
Question Re: editing XF86Config. in suse linux for nvidia driver

looking at the readme file is somewhat confusing to me concerneing what i am supposed to be entering into it for configuration so i have taken the liberty of typing in the conole as root this command : edit XF86Config. which gave me this output


generic XFree86 4.x configuration file

Section "Files"
FontPath "/usr/X11R6/lib/X11/fonts/truetype/"
FontPath "/usr/X11R6/lib/X11/fonts/URW/"
FontPath "/usr/X11R6/lib/X11/fonts/uni/"
FontPath "/usr/X11R6/lib/X11/fonts/misc/"
ModulePath "/usr/X11R6/lib/modules"
RgbPath "/usr/X11R6/lib/X11/rgb"
InputDevices "/dev/ttyS0"
InputDevices "/dev/ttyS1"
InputDevices "/dev/ttyS2"
InputDevices "/dev/ttyS3"
InputDevices "/dev/ttyS4"
InputDevices "/dev/ttyS5"
InputDevices "/dev/ttyS6"
InputDevices "/dev/ttyS7"
InputDevices "/dev/ttyS8"
InputDevices "/dev/psaux"
InputDevices "/dev/logibm"
InputDevices "/dev/sunmouse"
InputDevices "/dev/atibm"
InputDevices "/dev/amigamouse"
"/etc/X11/XF86Config" [readonly] 183L, 4174C 1,1 Top


i also checked the log file to see what version of the config file that is being used by my system entering the same command with the log file i recieved this output

This is a pre-release version of XFree86, and is not supported in any
way. Bugs may be reported to XFree86@XFree86.Org and patches submitted
to fixes@XFree86.Org. Before reporting bugs in pre-release versions,
please check the latest version in the XFree86 CVS repository
(http://www.XFree86.Org/cvs).

XFree86 Version 4.3.0.1
Release Date: 9 May 2003
X Protocol Version 11, Revision 0, Release 6.6
Build Operating System: SuSE Linux [ELF] SuSE
Build Date: 12 February 2004
Before reporting problems, check http://www.XFree86.Org/
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Sun May 9 12:46:12 2004
(==) Using config file: "/etc/X11/XF86Config"
(==) ServerLayout "Layout[all]"
(**) |-->Screen "Screen[fbdev]" (0)
(**) | |-->Monitor "Monitor[0]"
"/var/log/XFree86.0.log" 450L, 21674C

my reason for this output is the version of my program which is displayed above.

the readme doesnot tell me how to edit these files to make x server use the drivers that i installed being 1.0 5336. can someone baby step me through how to achieve this with the above information displayed
thanks for the patience
khalid357
khalid357 is offline   Reply With Quote