View Single Post
Old 05-13-04, 07:22 PM   #4
hppnq
Registered User
 
Join Date: Apr 2004
Location: Dutch
Posts: 113
Default Re: RH9 Ethernet problem is still!!!

No, I really meant the kernel-source rpm. ;-)

Either the kernel-source rpm is not installed, or the installer doesn't know where to find the kernel sources. Both are easily fixable.

First, check whether the sources are installed by issuing:

# rpm -q kernel-source

This shows you which kernel=sources you have installed. It should therefore produce at least one line, probably "kernel-source-2.4.20-8". If the output shows a different version than the output of the command

# uname -r

which is the version of the kernel you are currently running (probably 2.4.20-8), you should install the kernel-source rpm for this latter version. You should also do this, of course, if you found you haven't got any kernel sources installed. You will find them on one of the RedHat cd's, or on the web.

If you do already have the kernel sources, the problem is that the installer cannot find them. You should then pass the option --kernel-source-path=<path> to the installer, where path is the directory where the kernel sources reside.

UPDATE: Reading your post again, you are using make, so you cannot pass this option to the installer. ;-) Post the makefile then, if necessary.

Now, if the kernel sources are present in /usr/src/linux (the default), and you still get compiler errors, check for the existence of the symbolic link /lib/modules/2.4.20-8/build (change kernel version if applicable) -- it should point to the directory where the kernel sources are, in this case probably /usr/src/linux-2.4.20-8 (/usr/src/linux could also be a link to this directory, by the way).
hppnq is offline   Reply With Quote