View Single Post
Old 05-15-04, 04:44 PM   #2
jerickson314
Registered User
 
Join Date: May 2004
Posts: 43
Default Re: complete system crash when i start x server

Try disabling AGP support. The card will still work when connected to an AGP port, but will have somewhat slower performance. Still, it should function.

1.) Start SaX2. ("sax2 -m 0=nvidia" from runlevel 3)
If this does not work see below.
2.) Choose "Graphics Card" under "Display" and click the "Change Configuration" button.
3.) On the dialog that pops up, go to the Expert tab.
4.) Under "Card Options", click on "NvAGP".
5.) Select "0" on the box it brings up.
6.) Save the settings and restart the graphics system as usual with SaX2.

If SaX2 does not work even using the command as detailed above try adding the line:
Option "NvAGP" "0"
under section "Device" of /etc/X11/XF86Config
Then startx should work and you can configure XFree86 from SaX2 by running it from X. (Such as running it from KDE). When you do so, make sure SaX is set to use NvAGP 0 as directed above.
jerickson314 is offline   Reply With Quote