View Single Post
Old 05-19-04, 11:10 AM   #5
Registered User
Join Date: May 2004
Posts: 5
Default Re: nvidia driver goes wacky on restart or shutdown (mandrake 9.2)

Bingo. You solved it rednuht.

For anyone else having this problem, I've attached the X config file that is working for me.

Interestingly, the documentation (see [snip] below) suggests employing Option "IgnoreDisplayDevices" as a potential remedy for long delays in starting X. It seems it may also apply for a display problem during the shutdown process. At least in this case it did.

Cheers, and thanks again rednuht.
Apologies to nVidia for suspecting the nvidia driver as the culprit.

Option "IgnoreDisplayDevices" "string"
This option tells the NVIDIA kernel module to completely
ignore the indicated classes of display devices when
checking what display devices are connected. You may
specify a comma-separated list containing any of "CRT",
"DFP", and "TV".

For example:

Option "IgnoreDisplayDevices" "DFP, TV"

will cause the NVIDIA driver to not attempt to detect
if any flatpanels or TVs are connected.

This option is not normally necessary; however, some video
BIOSes contain incorrect information about what display
devices may be connected, or what i2c port should be
used for detection. These errors can cause long delays
in starting X. If you are experiencing such delays, you
may be able to avoid this by telling the NVIDIA driver to
ignore display devices which you know are not connected.

NOTE: anything attached to a 15 pin VGA connector is
regarded by the driver as a CRT. "DFP" should only be
used to refer to flatpanels connected via a DVI port.
Attached Files
File Type: txt XF86Config-4_v3.txt (3.2 KB, 214 views)
maroon is offline   Reply With Quote