View Single Post
Old 05-21-04, 08:25 AM   #17
oyvind
Registered User
 
Join Date: May 2004
Location: Norway
Posts: 117
Default Re: Fedora Core 2 - lockup problems

Drifting slightly off topic now, but anyway:

First of all: if things are working fine and you're not annoyed by any problems, you could always say "If it ain't broke, don't fix it" .

XFS is, IMO, an archaic thing of old times, no longer necessary for X fonts. But if you want to, by all means, use it, you will probably not notice any difference. Either start up XFS (and check it's config) and uncomment the "unix/:7100" fontpath, or just leave it out, and put your systems font locations directly into xorg.conf.

The line tells the X server that it should look for fonts from a font server running at unix socket port 7100 (which is XFS). If that server isn't running, or not configured properly, X will probably fail. But since X also can look for fonts from directories in your system (look in /etc/X11/fs/config), you could simply just put in these instead, like I suggested earlier.

Many of todays modern X apps use the XFT/fontconfig solution (client side fonts), for example all KDE3/GNOME/GTK2 apps will use this. It's easy to identify: The XFT/fontconfig enabled clients' fonts are usually rendered with anti-aliasing (default), and have sane human readable names, like `Monospace 9', instead of `-monotype-courier new-bold-r-*-*-*-*-*-*-*-*-*-*'. The point is that this solution is not dependent(AFAIK) upon the old X-server provided fonts (which are configured in xorg.conf). They will therefore pay no attention to missing fonts there. But still, I find it weird your X server starts without XFS and no fontpaths configured in xorg.conf at all, perhaps the location of the "Fixed" font (necessary for X to run at all) is hardcoded into the server, for "emergencies". Check `/var/log/Xorg.0.log' for possible answers.

Hey, isn't this a nVIDIA driver forum, time to stop writing now=).
oyvind is offline   Reply With Quote