View Single Post
Old 05-24-04, 04:25 PM   #4
jerickson314
Registered User
 
Join Date: May 2004
Posts: 43
Default Re: X freezes with FX5200

I was mistaken the first time, the default option does try agpgart before it tries NvAGP. You might want to try NvAGP 1, which uses nVidia's proprietary AGP driver. However, the KT400 chipset on the A7V8X-X is not officially supported by that option, and when I tried it on SuSE 9.0 (kernel 2.4) it gave my system frequent crashes.
One thing you may want to try is to disable the framebuffer (remove any "vga=" and/or "splash=" options from your GRUB or LILO configuration for booting Linux). This will revert the consoles to 640x480 with no bootsplash, but it may help with your stability problems.

When the system crashes is there a message on the system log about "Badness in pci_find_subsys"? This is a common issue. I did discover that on my system with NvAGP 2 my system still sometimes crashes, but infrequently. When it does crash, it leaves the error message. You can search the forums for that text to find out more about that problem or for suggestions. I do believe nVidia is working on a fix.

BTW, I have just started testing the system with AGP enabled but the framebuffer disabled; sometimes a bad setup won't crash on me for several days so I don't know if that fixed the problem for me. I did try updating my BIOS to the latest from Asus and it didn't help me; in fact it kept me from being able to enter Setup most of the time so I reverted to the original BIOS I had backed up. So if you try upgrading the BIOS, make sure you make a backup copy of the old version first in case there is trouble. There are instructions in the motherboard manual and on Asus's web site for how to do that. The easiest way to make a DOS boot disk on Linux is to enter the commands given in the instructions into dosemu.
jerickson314 is offline   Reply With Quote