View Single Post
Old 11-04-02, 09:30 AM   #8
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

You'd need both of those IDs, actually.

In include/pci_ids.h (from the base directory of the 2.4.19 kernel; other recent 2.4 kernels would hopefully be the same), in the section where it has DEVICE_ID_VIA_xxxxx, add a couple of lines (preferably at the end of that section):

#define DEVICE_ID_VIA_8235_0 0x3189
#define DEVICE_ID_VIA_8235_1 0xb168


Save and exit your editor, and then open up drivers/char/agp/agpgart_be.c and add a device descriptor near the end. Do a search for CONFIG_AGP_VIA, and look around the third hit.

Down a bit further, there should be a set of lines looking like:

Code:
	{ PCI_DEVICE_ID_VIA_8367_0,
		PCI_VENDOR_ID_VIA,
		VIA_APOLLO_KT133,
		"Via",
		"Apollo Pro KT266",
		via_generic_setup },
Right after that, insert another section that looks almost the same:

Code:
	{ PCI_DEVICE_ID_VIA_8235_0,
		PCI_VENDOR_ID_VIA,
		VIA_APOLLO_KT133,
		"Via",
		"Apollo Pro KT266",
		via_generic_setup },
Then recompile the kernel and see that first, the AGP devices are detected properly in /proc/pci, and second, whether you can initialize AGP when you load the NVdriver and agpgart modules. You can just modprobe NVdriver, then modprobe agpgart, then check /proc/driver/nvidia/agp/status for whether or not it's initialized. Then try to startx (using agpgart), and see if you still get lockups. Also, you'll want to make sure you have your AGP stuff set to 4x everywhere -- which means that you'll probably want to set up options NVdriver NVreg_EnableVia4x=1 in your modules.conf as well. The KT400 chipset doesn't support the higher voltage ofthe older AGP 1x/2x cards, so it could be that when the nVidia driver requests 2x mode, the motherboard says "I can't do that", so it gets disabled.

Actually, now that I think about it, you might want to try that options line first...
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote