View Single Post
Old 07-01-04, 04:07 AM   #34
Leviathan
Registered User
 
Join Date: Mar 2004
Posts: 11
Default Re: 1.0-6106 for X86-32 thread

Quote:
Originally Posted by elFarto
Code:
[root@thor root]$ cat /proc/driver/nvidia/agp/*
Fast Writes:     Supported
SBA:             Supported
AGP Rates:       4x 2x 1x
Registers:       0x1f000217:0x00000000
Host Bridge:     Silicon Integrated Systems [SiS] SiS645DX Host & Memory & AGP Controller
Fast Writes:     Not Supported
SBA:             Supported
AGP Rates:       4x 2x 1x
Registers:       0x1f000207:0x00000000
Status:          Disabled
 
AGP initialization failed, please check the ouput
of the 'dmesg' command and/or your system log file
for additional information on this setup problem.
And X still locks up solid weather you I AGPGART or NvAGP.

[sarcasm]
But on the good side, I don't have any badness in pci_find_subsys in my syslog.
[/sarcasm]

I really hoped Nvidia had solved this issue, but alas, they haven't.

Regards
Stephen
This might not be a nvidia-issue at all!
Some SIS-Board have a timing bug that crashes X for the first start, this happened to me too.
This should have been fixed in the newest kernel versions (2.6.6/2.6.7) by adding an additional wait, but it still doesn't work for me.
The solution I use is starting a program named "testgart" before I run X. Testgart runs into the same timing bug that X would, but it doesn't crash the system. After that, X should run smoothly (all with agpgart that is)

Good Luck
Leviathan is offline   Reply With Quote