View Single Post
Old 07-24-04, 07:00 PM   #2
MightyPenguin
Registered User
 
MightyPenguin's Avatar
 
Join Date: Mar 2003
Posts: 15
Default Re: Xorg, Nvidia -> black screen of death.

First off if you're using a 2.6.x kernel make sure that /usr/src/linux is a symlink that points to it e.g. /usr/src/linux -> /usr/src/linux-2.6.7

It's possible you compiled the nvidia driver with kernel headers that were for another kernel. If you don't want to do this, you can use an option with the nvidia installer to tell it where to look for the kernel headers, just use the --help flag with it to see what that flag is and how to set it.

Also, if you can recompile your kernel, disable io-apic and APIC in general. Also disable ACPI. Those two things made my stability much worse with nvidia drivers in the past, and the serious users I know refuse to use at least ACPI (io-acpi is still maturing).

It does appear this release adds a lot of new features which may account for many of the problem it has. For me, 5336 worked just great.
__________________
Do not meddle in the affairs of kernel programmers for they are subtle and quick to anger.
MightyPenguin is offline   Reply With Quote