View Single Post
Old 09-05-04, 09:30 AM   #1
beamland
Registered User
 
Join Date: Jun 2004
Posts: 1
Default can't load module nvsound (0283)

Searched the archives and googled around for hours now but still couldn't find something really helpful to solve my problem.

I'm desperately trying to install the new nforce driver 0283 to enable ac3 hardware passthrough on my system (Soltek EQ3702A with nForce2 MCP-T chipset). Just wanted to activate spdif optical out to connect to my av-receiver for dd 5.1.

The problem is:

When running sh NFORCE-Linux-x86-1.0-0283-pkg1.run I choose to only install the nvsound module (not yet interested in nvnet because forcedeth work well enough for me). As far as I can tell, th installer compiles nvsound.o without problems but then fails to load the module. I get the following error (nvidia-nforce-installer.log):

Code:
root@mythtvmbe:/var/log # cat nvidia-nforce-installer.log
nforce-installer log file '/var/log/nvidia-nforce-installer.log'
creation time: Sun Sep  5 15:21:37 2004

option status:
  license pre-accepted      : false
  expert                    : false
  uninstall                 : false
  driver info               : false
  no precompiled interface  : false
  no ncurses color          : false
  no questions              : false
  silent                    : false
  Installer install prefix  : /usr
  kernel source path        : (not specified)
  net kernel install path   : (not specified)
  audio kernel install path : (not specified)
  proc mount point          : /proc
  ui                        : (not specified)
  tmpdir                    : /tmp

Using: nvidia-installer ncurses user interface
-> Found package NVIDIA network driver for Linux-x86
-> Found package NVIDIA audio driver for Linux-x86
-> Please select packages for installation:
   Selections:
   NVIDIA audio driver for Linux-x86 (1.0-0)
-> Starting install of NVIDIA audio driver for Linux-x86
-> Checking for loaded module nvsound
-> Checking for loaded module nvaudio
-> License accepted.
-> Skipping check for conflicting rpms.
-> /proc/version is Linux version 2.4.25-chw (root@km_dev.mysettopbox.tv) (gcc
   version 3.3.2 20030812 (Debian prerelease)) #1 Sat Apr 10 15:46:31 PDT 2004
-> No precompiled kernel interface was found to match your kernel; this means
   that the installer will need to compile a new kernel interface.
-> Kernel source path: '/lib/modules/2.4.25-chw/build'
-> Performing cc_version_check with CC="cc".
-> running command /bin/grep "^PATCHLEVEL ="
   /lib/modules/2.4.25-chw/build/Makefile | /usr/bin/cut -d " " -f 3
-> Kernel module filename is nvsound.o
   Cleaning kernel module build directory.
   executing: 'cd ./nvsound/main; make clean'...
   rm -f nv*.o *~ core
-> Building kernel module:
   executing: 'cd ./nvsound/main; make module SYSSRC=/lib/modules/2.4.25-chw/bu
   ild'...
   cc -Wall -Wstrict-prototypes -Wno-trigraphs -O2 -fno-strict-aliasing -fno-co
   mmon -fomit-frame-pointer  -I/lib/modules/2.4.25-chw/build/include -O -mpref
   erred-stack-boundary=2 -march=i686    -D__KERNEL__ -DMODULE -DLINUX  -I.  -D
   MODVERSIONS -include /lib/modules/2.4.25-chw/build/include/linux/modversions
   .h   -c -o nvmain.o nvmain.c
   nvmain.c:977: Warnung: `Nvprint_ioctl' defined but not used
   cc -Wall -Wstrict-prototypes -Wno-trigraphs -O2 -fno-strict-aliasing -fno-co
   mmon -fomit-frame-pointer  -I/lib/modules/2.4.25-chw/build/include -O -mpref
   erred-stack-boundary=2 -march=i686    -D__KERNEL__ -DMODULE -DLINUX  -I.  -D
   MODVERSIONS -include /lib/modules/2.4.25-chw/build/include/linux/modversions
   .h   -c -o nvmixer.o nvmixer.c
   cc -Wall -Wstrict-prototypes -Wno-trigraphs -O2 -fno-strict-aliasing -fno-co
   mmon -fomit-frame-pointer  -I/lib/modules/2.4.25-chw/build/include -O -mpref
   erred-stack-boundary=2 -march=i686    -D__KERNEL__ -DMODULE -DLINUX  -I.  -D
   MODVERSIONS -include /lib/modules/2.4.25-chw/build/include/linux/mo
   dversions.h   -c -o nvalinux.o nvalinux.c
   ld -r -o nvsoundif.o nvmain.o nvmixer.o nvalinux.o
   ld -r -o nvsound.o nvsoundif.o mcpmain.o
-> done.
-> Kernel module compilation complete.
-> Testing kernel module:
-> Copying test module ./nvsound/main/nvsound.o to
   /lib/modules/2.4.25-chw/kernel/drivers/sound/nvsound.o
ERROR: Unable to load the kernel module 'nvsound.o'.  This is most likely
       because the kernel module was built using the wrong kernel source files.
       Please make sure you have installed the kernel source files for your
       kernel; on Red Hat Linux systems, for example, be sure you have the
       'kernel-source' rpm installed.  If you know the correct kernel source
       files are installed, you may specify the kernel source path with the
       '--kernel-source-path' commandline option.
-> Kernel module load error: modprobe: Can't locate module nvsound
-> Testing completed.
ERROR: Installation of the audio driver has failed.  Please see the file
       '/var/log/nvidia-nforce-installer.log' for details.  You may find
       suggestions on  fixing installation problems in the README available on
       the Linux driver download page at www.nvidia.com.
I'm running KnoppMyth distro with its 2.4.25-chw kernel.

Anyone any ideas what I could do? Don't think it's a kernel source path (or similar) problem, because installation of the NVIDIA-Linux-x86-1.0-6111-pkg1.run driver went well!
beamland is offline   Reply With Quote