Thread: Memory Leak!
View Single Post
Old 11-24-02, 01:18 AM   #16
Phyre
Registered User
 
Phyre's Avatar
 
Join Date: Jul 2002
Location: Central Louisiana
Posts: 323
Default

Chalnoth, check out the hdparm command. It's in /sbin, so you might have to invoke it with /sbin/hdparm. As root (su), run this command to see what kind of rates you're getting:

/sbin/hdparm -Tt /dev/hdx (where x is your linux drive).

To enable DMA, su and type /sbin/hdparm -d1 /dev/hdx. There are other things you can to do with hdparm to boost the performance of your drive too. This might help ya out in that respect.

http://www.linuxnetmag.com/en/issue7/m7hdparm1.html

Once you have the settings that you need for your drive, you can put them in your rc.d file so that they will load every time. Can't remember exactly which rc.d file. I have to do a search on it everytime I reinstall. LOL

Also, what motherboard/chipset are you using. I'm not sure if it's been fixed in RedHat 8, but VIA used to have problems with not beeing able to get to ATA100 modes. The source for it's module had to be modified a bit, hence forcing a rebuild of the kernel.

Hope this gets you a little further into this caper.

Phyre
Phyre is offline   Reply With Quote