View Single Post
Old 09-17-04, 03:48 PM   #2
Kaitain
AOA*****s.com
 
Join Date: Aug 2004
Location: London, UK
Posts: 5
Default Re: NFORCE 0283 nvsound module : Error : illegal write

Same issue here:

Using kernel-2.6.7-gentoo-r11 it all works just fine - the module inserts and I get working sound without that annoying hiss inherent in the snd-intel8x0 module.

Using kernel-2.6.8-gentoo-r4 I get this error popping up in KDE:
Code:
Sound server fatal error:
AudioSubSystem::handleIO: write failed
len = -1, can_write = 4096, errno = 29 (Illegal seek)
The relevant output from dmesg is:
Code:
Nvsound: Nvidia Audio Init Module, 21:31:02 Sep 17 2004 version 1.0-0
ACPI: PCI interrupt 0000:00:06.0[A] -> GSI 5 (level, low) -> IRQ 5
PCI: Setting latency timer of device 0000:00:06.0 to 64
Nvsound: NVIDIA CK8S Audio found at IO 0xc000 and 0xbc00, IRQ 5
Nvsound: Aci_device 000001003fcd9800 Apu_device 0000000000000000
Nvsound: DEV MIXER 0 DEV AUDIO 3
Nvsound: Set format as 10
Nvsound: Unable to change the Record SampleRate, set back to 48000
Nvsound: Value a000c
Nvsound: fragment size a fragnum c
Nvsound: Nvaudio_release
Nvsound: Set format as 10
Nvsound: Value a000c
Nvsound: fragment size a fragnum c
Nvsound: Nvaudio_release
Nvsound: Set format as 10
Nvsound: Value a000c
Nvsound: fragment size a fragnum c
(This obtained from a sound server restart)

What's interesting is that lsmod suggests that the module inserts correctly, but that it isn't linked to the other components that use it:
Code:
Module                  Size  Used by
snd_seq_oss            37632  0
snd_seq_midi_event      9472  1 snd_seq_oss
snd_seq                58560  4 snd_seq_oss,snd_seq_midi_event
snd_seq_device          9292  2 snd_seq_oss,snd_seq
snd_pcm_oss            58408  0
snd_pcm               109452  1 snd_pcm_oss
snd_page_alloc         12944  1 snd_pcm
snd_timer              28232  2 snd_seq,snd_pcm
snd_mixer_oss          20544  1 snd_pcm_oss
snd                    62632  8 snd_seq_oss,snd_seq_midi_event,snd_seq,snd_seq_device,snd_pcm_oss,snd_pcm,snd_timer,snd_mixer_oss
nvsound              1854096  0
nvidia               5290644  12
I used essentially the same config for kernel 2.6.8 as for 2.6.7, only changing those bits that really needed changing. The only parts of my system built as modules are for sound and video.

Software:
2.6.8-gentoo-r4 compiled for x86_64
gcc 3.3.4
glibc 2.3.4

Relevant Hardware:
Epox 8KDA3+

I'll use the intel8x0 module for now, but that hissing is doing my nut, so if anyone has any clues why it should suddenly stop working in kernel 2.6.8 I'd be pleased to find out
Kaitain is offline   Reply With Quote