View Single Post
Old 09-28-04, 10:51 PM   #1
mobrien
Registered User
 
Join Date: Sep 2004
Posts: 5
Default 3 Monitors Working, but can't "reach" one

After about 2 hours of messing with and debugging my xorg.conf file I've managed to get my setuip working exactly as I want it. Well almost exactly.

I'm running Fedora Core 2 with the 2.6.8 kernel. I have a P4 with Hyperthreading, but it's turned off. I am using the Nvidia driver ('nvidia' in xorg.conf) and i haven't had a problem (knocking on my desk). I have 2 video cards and 3 monitors.

Card 1: GeForce FX 5200 AGP 8x (good) PCI BusID 1:0:0
with connected monitors:
1-Dell FP1703 (17 inch flat panel) to DVI port (AWESOME)
2-Dell P780 (17 inch flat CRT) to VGA port (Good monitor) (above 1)

Card 2: GeForce2 MX400 PCI (cheap, but works) PCI BusID 2:0:0
with connected monitor:
Futura LDF770 (a decent generic flat screen CRT)

I was so proud of myself in getting them all to work, and I have TwinView running so that the P780 is running at 1024x768, but spans 1280 width because my 1703FP is running at its native resolution of 1280x1024. All of this works great and I can span these two monitors or whatever.

Also, the Futura monitor is running a seperate session of KDE (Gnome sucks). This sesion appears to be fully functional, a screen saver even comes on, but I can't direct any input to it. It is so terrible because I CAN SEE IT RIGHT THERE, the light at the end of the tunnel, but I JUST CAN'T REACH IT!!!

Since it thinks my two monitors are one "screen" ("Screen1" due to all the commotion) The other screen is labeled "ScreenMX".

Well, I declare: Screen 0 "Screen1" , This is my two screens

and i've tried

Screen 1 "ScreenMX" LeftOf "Screen1"
*and*
Screen 1 "ScreenMX" Above "Screen1"
*and*
Screen 1 "ScreenMX" Relative "Screen1" 1280 768
(which should put it to the right of my flat panel)

I still haven't placed a cursor (mouse or keyboard) on the 3rd monitor.

Anyway, I like this setup. It's exectly the way I want it. I have a crystal clear picture on every monitor, i just can't use one. It is not imperative that I get them all working, but I would like to. I thgought this would be a fun thing for anyone who is interested in to ponder. I've attachd my xorg.conf file (xorg.conf.txt) for anyone who is interested in it or thinks they can help me out. Check it out. Sorry for the long post.

--mobrien
Attached Files
File Type: txt xorg.conf.txt (4.4 KB, 196 views)
mobrien is offline   Reply With Quote