View Single Post
Old 10-09-04, 12:19 PM   #1
fgava
Registered User
 
Join Date: Oct 2004
Posts: 4
Question Failed to initialize the NVIDIA kernel module!

Hi,
Everything was ok running the driver 1.0-6106, but I decided to upgrade to 6111...
I installed with no errors, the module was up, but when I start X, I get an error:

[...]
(II) Setting vga for screen 0.
(II) Loading sub module "vgahw"
(II) LoadModule: "vgahw"
(II) Loading /usr/X11R6/lib/modules/libvgahw.a
(II) Module vgahw: vendor="X.Org Foundation"
compiled for 6.7.0, module version = 0.1.0
ABI class: X.Org Video Driver, version 0.7
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "NvAGP" "3"
(--) NVIDIA(0): Linear framebuffer at 0xE8000000
(--) NVIDIA(0): MMIO registers at 0xFD000000
(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module!
(EE) NVIDIA(0): *** Aborting ***

(II) UnloadModule: "nvidia"
(II) UnloadModule: "vgahw"
(II) Unloading /usr/X11R6/lib/modules/libvgahw.a
(EE) Screen(s) found, but none have a usable configuration

The conf is ok, the same when 6106 was installed
I'm running Slackware 10 with Kernel 2.6.7
I tryed do downgrade to 6106 with no success, installation ok, but the same error typing startx!
Kernel headers and source (2.6.7) are installed...
I'm using 'nv' now, but I _need_ to play doom3!

Thanks in advance
fgava
fgava is offline   Reply With Quote