View Single Post
Old 12-02-02, 07:52 PM   #1
adrin
Registered User
 
Join Date: Dec 2002
Posts: 4
Default two problems with Nvidia_kernel-1.0-3123

I have two potentially related problems, which I hope gurus on this list will be able to resolve:

I have an AMD Athlon MP-based linux box with a Quadro 4 XGL 700 installed.

With Red Hat 7.3, kernel version 2.4.18-3 and Nvidia_kernel-1.0-2960 and its corresponding GLX files everything works ok.

I've upgraded the kernel to version 2.4.18-18.7.x; and I've downloaded Nvidia_kernel-1.0-3123 for Athlon and the corresponding GLX files. I had difficulty with the rpm approach, so I've used the tar files to install.

Everything compiles (and installs?) without error messages; however:

(1) The NVdriver does not load automatically at boot time, and yes "alias char-major-195 NVdriver" exists in /etc/modules.conf

(2) For some reason the driver does not recognize the monitor and when I use startx, the monitor signals "No Sync" and the linux box reboots itself!

GLcore and dri modules are deleted in XF86Config-4; glx is loaded, and "vesa" is replaced with "nvidia" in the same config file. The monitor I use is Viewsonic VX800, 18" digital flat screen, so as with the previous kernel version that worked perfectly well, I have assigned the horizontal and vertical frequency ranges as well as the resolution in XF86Config-4. However, for some reason startx just won't start properly.

I have checked ALL the files for their existence in the correct directories and with the correct links, as outlined in the NVLinuxR25Notes_3123 notes and have exhausted all tests.

I'd really appreciate any help I can get

adrin
adrin is offline   Reply With Quote