View Single Post
Old 08-03-02, 11:58 PM   #5
ScuzziOne
Guest
 
Posts: n/a
Default

I'm running a Visiontek GeForce4 Xtasy MX440 under RedHat7.3. The default drivers with RH7.3 also locked my system up when starting the X server. Downloaded and installed the latest drivers (version 1.0-2960) from the nVidia website to correct the problem. Since you can't start the X server, you'll need to boot up in non-graphical mode (run level 3, I believe) and install the drivers there. Don't recall off-hand exactly how I got set up to boot to non-graphical. I believe there was some sort of recovery or shell option on the installation CD that I used modify my /etc/inittab file. Anyway, however you do it, you need to modify the default run level in the /etc/inittab file to run level 3 (or whatever level full-up non-graphical is... assuming my memory may be a little foggy! It tells you what levels are what via comments in this file.) There may also be other ways to boot non-graphical... anybody???

Anyway, once you're booting non-graphical, you can install the new drivers, modify your /etc/X11/XF86Config-4 file using vi, and type startx to try out your setup. If you manage to get locked up, simply reboot back around and have at your XF86Config-4 file again to correct whatever is goofed. Keep this up until startx correctly fires up X. Once everything is working, you can then modify the /etc/inittab file back to graphical default if you'd like.

Best of Luck!
  Reply With Quote