View Single Post
Old 12-02-04, 10:02 AM   #1
ildefonso
Registered User
 
Join Date: Nov 2004
Posts: 5
Default Only 48000 Hz sample rate, and no 5.1 sound with nforce3 linux 2.4 or 2.6.

I have had this problem:

icamargo@kirara:~$ esd
unsupported playback rate: 44100
Audio device open for 44.1Khz, stereo, 16bit failed
Trying 44.1Khz, 8bit stereo.
unsupported playback rate: 44100
Audio device open for 44.1Khz, stereo, 8bit failed
Trying 48Khz, 16bit stereo.

and there is no way in wich I can make it work for any other rate than 48000. I tried with the i810_audio driver too, and it didn't worked. And I hasn't been able to make it work with 5.1 sound, nor 4 speakers, only stereo (with the nforce driver or with i810, I just can't).

Right now I'm using the nvsound driver because it is the last one I installed, and due that it works just the same, I left it there.

Off course, I get a similar problem with doom 3 (wich, either, I have no sound, or I have to use esd and esddsp in order to resample the sound). It just says that can't open the device for 44100 Hz.

I have a Athlon 64 3000+ with a Chaintech NF250 mother board (nf3 chipset, I think, it says that it is nForce3).

This is my lspci output:

kirara:~# lspci
0000:00:00.0 Host bridge: nVidia Corporation: Unknown device 00e1 (rev a1)
0000:00:01.0 ISA bridge: nVidia Corporation: Unknown device 00e0 (rev a2)
0000:00:01.1 SMBus: nVidia Corporation: Unknown device 00e4 (rev a1)
0000:00:02.0 USB Controller: nVidia Corporation: Unknown device 00e7 (rev a1)
0000:00:02.1 USB Controller: nVidia Corporation: Unknown device 00e7 (rev a1)
0000:00:02.2 USB Controller: nVidia Corporation: Unknown device 00e8 (rev a2)
0000:00:06.0 Multimedia audio controller: nVidia Corporation: Unknown device 00ea (rev a1)
0000:00:08.0 IDE interface: nVidia Corporation: Unknown device 00e5 (rev a2)
0000:00:0a.0 IDE interface: nVidia Corporation: Unknown device 00e3 (rev a2)
0000:00:0b.0 PCI bridge: nVidia Corporation: Unknown device 00e2 (rev a2)
0000:00:0e.0 PCI bridge: nVidia Corporation: Unknown device 00ed (rev a2)
0000:00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 NorthBridge
0000:00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 NorthBridge
0000:00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 NorthBridge
0000:00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 NorthBridge
0000:01:00.0 VGA compatible controller: nVidia Corporation NV11DDR [GeForce2 MX 100 DDR/200 DDR] (rev b2)
0000:02:0d.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)

Any ideas?

Thanks in advance for your help,

Ildefonso.
ildefonso is offline   Reply With Quote