Thread: Games on Linux
View Single Post
Old 12-15-02, 04:32 AM   #9
tuxfriend
Registered User
 
Join Date: Jul 2002
Location: Muelheim/Ruhr Germany
Posts: 27
Default

Q: I've just bought Unreal Tournament 2003, and i can't get it to install. The installer on the third disk asks me to install the "PLAY" disk, but no matter which disk i try, they all fail. What's wrong?
A: The Linux installer asks for the wrong disc names. This was the
results of an unfortunate miscommunication right before the disc went
gold. The installer will ask for "play disc", "disc 1", "disc 2". What
it should ask for is "disc 1", "disc 2", "disc 3". This is
obnoxious, but it is not fatal, as the text is just used in the
user interface, and is not used in detecting the disc. Just put
in the disc it wants, not the one it asks for.
A: Note that, perhaps most importantly, the other questions about the original Unreal Tournament apply. Especially with regard to joilet support. When you mount disc 3 to look for the installer, you should see linux_installer.sh, not linux_in.sh. The option you want (as far as my 2.4.19-based system is concerned) in the kernel configuration is under "Filesystems". Enable "ISO 9660 CDROM file system support" and then "Microsoft Joliet CDROM extensions". If there is a "Rock Ridge extensions" option, enable that too.
A: Do not sit on the mount point, or you won't be able to switch discs. So if
you do this (or something like it):
mount -t iso9660 -r /dev/cdrom /mnt
cd /mnt
./linux_installer.sh
You won't be able to unmout the disc when the installer asks for the next disc
in the series, since your shell is still sitting in the mountpoint. It will
work better if you do something more like this:
mount -t iso9660 -r /dev/cdrom /mnt
cd /somewhere/else
/mnt/linux_installer.sh
The installer copies itself to $TMPDIR before running, so it shouldn't
be sitting on the mountpoint. If this still isn't working, copy the installer
yourself, to make sure it is not blocking your unmount:
mount -t iso9660 -r /dev/cdrom /mnt
cp /mnt/linux_installer.sh $HOME
umount /mnt (this is making sure the disc is unmountable)
$HOME/linux_installer.sh
A: Are you using Mandrake? If so, you will probably need to disable supermount for your CDROM/DVDROM drive, since it appears to be interfering with the installer's ability to detect the CDROM properly. To turn it off, run drakconf, go to "Mount Points" -> DVD (or CDROM) -> Options -> uncheck supermount.
Save your changes, make sure the CDs are completely unmounted, and then try the installer again. you'll need to manually mount the cdroms, insert disk 3, run the installer, and it should work fine now.
Other distributions will need to use their way of turning off supermount, although we don't know of any others that use it by default.
A: If you get a bunch of errors to the console for each file installed, talking
about different devices in your /etc/fstab, they can (usually) be ignored. If
they are causing trouble, temporarily comment those lines out of fstab.
(If that makes you nervous, the SETUP_CDROM environment variable described
below accomplishes this better.)
A: If you have multiple CD drives, and the installer is continuously
grinding the one you're not currently installing off, then tells you
"mount: no media" or similar, just stuff one of the other ut2k3 CDs into
that drive. The installer will even pick up on that and save you a disk
change later.
A: If you are SURE you've got the correct disc mounted and the installer seems
to disagree, export the environment SETUP_CDROM before running the installer,
and you might be able to fool it (this is untested):
export SETUP_CDROM=/where/i/mounted/the/cdrom
/where/i/mounted/the/cdrom/linux_installer.sh
The installer doesn't care if it's really a CD, so if you get really desperate,
you can copy it to your harddrive or mount an ISO on a loopback device, etc.
The installer just looks for files in a directory tree to decide if the CD-ROM
is mounted. If you've got multiple CD-ROM or DVD-ROM drives, mount a disc
in each and export SETUP_CDROM_CD1, SETUP_CDROM_CD2, and SETUP_CDROM_CD3, and the installer will go directly to those locations for the needed files.
A: The installer will seem to install some stuff very fast, and then really
REALLY slow down, taking a long time for individual files. THIS IS NORMAL.
Files that are compressed into Epic's "uz2" format take a long time to
uncompress. This is the bulk of the installer's work. This game takes a LONG
time to install (you are, after all, uncompressing about 2.5 gigs worth of
data).
A: Read this: https://bugzilla.icculus.org/show_bug.cgi?id=147,
and this: https://bugzilla.icculus.org/show_bug.cgi?id=147.
A: If none of the above works, consider e-mailing our mailing list after
subscribing as described above.
from http://www.icculus.org/lgfaq/
hope this helps
tuxfriend is offline   Reply With Quote