View Single Post
Old 08-04-02, 10:51 PM   #7
Posts: n/a
Default Ok try this...

Ok, I'm just comparing my XF86Config file to yours and I see a couple of differences. I don't know if any of this could help, but I guess it couldn't hurt.

First, go down to the modules area and comment out these lines by adding a # in front of them

#load "extmod"
#load "speedo"

And add into the modules section

load "v4l" // This does really cool stuff like window-only redraws when you move a xine video window around. Highly recommended.

Then change your

Options "dpms"

line to look like this:

Options "DPMS" "on"

After all this see if this makes any difference... if it doesn't...

I searched google groups to see if I could find some help for you and it turns out that maybe you're booting with a Virtual Frame Buffer device, which is kind of like a video driver, and maybe this driver is sticking around and screwing with X... This is a longshot, but try this...

1) First, as root, open up lilo.conf in your favorite editor.

2) look for a line that says


There's probably several of these lines... under different "images."

If it exists, then you're using a virtual frame buffer device.

3) What you want to do is disable the virtual frame buffer devices, so find the "label" or section which describes the kernel that you boot into at startup. And comment out that vga line like so...


Make sure to only comment out the vga line under the label which you use... You want to be sure to have other *unchanged* options to boot into in case this doesn't work.

4) As root, at the command prompt, type in...


This resets lilo so that your settings have been changed and you won't be booting into a virtual frame buffer device any more. Be warned though, that if something goes wrong your system can become unbootable... if you're unsure of what you're doing, post up your lilo.conf file and I can take a look at it.

I hope this helps, please let us all know if this works. And sorry if I went into a lot of details, I'm just not sure with how familiar you are with linux.

Good Luck,

Fred Hernandez
  Reply With Quote