View Single Post
Old 12-24-04, 11:11 AM   #1
Patrick_
Registered User
 
Join Date: Dec 2004
Posts: 1
Default NVIDIA, GLX problems

I've been having trouble with the NVIDIA driver and GLX for a while now. I had 6629, now have 6111.

I have Gentoo linux.

Here's my problem. The nv driver works fine. But as soon as I load the nvidia driver, the graphics are horrible... major discoloration, lines, etc etc.

I ran glxgears. Its giving me a Segmentation Fault and "Could not load mathcing GLX Library, couldn't find RGB" etc.

So anyway, today I tried installing the 6111 driver. I have nvidia-kernel, glx, and settings 6111 emerged. I get this error message:

ERROR: Unable to load the kernel module 'nvidia.ko'. This is most likely
because the kernel module was built using the wrong kernel source files.
Please make sure you have installed the kernel source files for your
kernel; on Red Hat Linux systems, for example, be sure you have the
'kernel-source' rpm installed. If you know the correct kernel source
files are installed, you may specify the kernel source path with the
'--kernel-source-path' commandline option.
-> Kernel module load error: insmod: error inserting './usr/src/nv/nvidia.ko':
-1 Unknown symbol in module


How do I do this in Gentoo? I'm sort of a newbie. This is really ticking me off! Can anyone PLEASE help me? Here's my xorg.conf and log. I've tried changing it so many times.

http://thepcelement.com/hardware/xorg.conf
http://thepcelement.com/hardware/Xorg.0.log

Thanks!
Patrick_ is offline   Reply With Quote