View Single Post
Old 01-20-05, 07:13 AM   #14
sergdarkstar
Registered User
 
Join Date: Jan 2005
Posts: 2
Default Re: DUAL HEAD ACHIEVED! xorg.conf Fedora Core 3 Build 2.6.9-1.681

I have a problem with connecting a second monitor (a TV using tv-out). TV is detected as main monitor and works. The LCD is detected but doesn't work. I can unplug the TV and use the same config for the LCD.

System specs:
Code:
Linux 2.6.9-1.667 #1 Tue Nov 2 14:41:25 EST 2004 i686 athlon i386 GNU/Linux
Code:
(II) NVIDIA X Driver  1.0-6629  Wed Nov  3 13:14:07 PST 2004
(II) NVIDIA Unified Driver for all NVIDIA GPUs
(II) Primary Device is: PCI 01:00:0
(--) Chipset NVIDIA GPU found
[...]
(II) NVIDIA(0): NVIDIA GPU detected as: GeForce4 Ti 4400
(--) NVIDIA(0): VideoBIOS: 04.25.00.22.00
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(II) NVIDIA(0): Detected AGP rate: 4X
The above is correct.

Using the tips from above, with changes to the monitor section I get in my Xorg.0.log the following:
Code:
(II) NVIDIA(0): Connected display device(s): DFP-0, TV-0
(WW) NVIDIA(0): Multiple displays connected, but only one display allowed;
(WW) NVIDIA(0):      using first display
(--) NVIDIA(0): Detected TV Encoder: Brooktree 871
and further down:
Code:
(II) NVIDIA(1): Connected display device(s): DFP-0, TV-0
(EE) NVIDIA(1): The requested configuration of display devices is not
(EE) NVIDIA(1):      supported by this driver.
(II) UnloadModule: "nvidia"
At some time I got something like this (but with NVIDIA instead):
Code:
(WW) NV: More than one matching Device section found: nvidia1
The problems are firstly that my TV seems to be the first monitor, I would like the main monitor to actually be the main monitor. Secondly I can't get them to work at the same time. The work just fine otherwise.

This is the relevant sections in the xorg.conf-file. (Full files attached)
Code:
Section "ServerLayout"
	Identifier "dual head configuration"
	Screen 0 "Screen0" 0 0
	Screen 1 "Screen1" RightOf "Screen0"
	InputDevice "Mouse0" "CorePointer"
	InputDevice "Keyboard0" "CoreKeyboard"
EndSection

# Main monitor (?) is a L1710B
Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "L1710B"
	DisplaySize  340	270
	HorizSync    30.0 - 71.0
	VertRefresh  56.0 - 75.0
	Option	    "dpms"
EndSection

# Secondary monitor is a TV.
Section "Monitor"
	Identifier   "Monitor1"
	VendorName   "Monitor Vendor"
	ModelName    "L1710B"
	DisplaySize  340	270
	HorizSync    30.0 - 71.0
	VertRefresh  56.0 - 75.0
	Option	    "dpms"
EndSection

Section "Device"
	# Edit the BusID with the location of your graphics card
	Identifier "nvidia0"
	Driver "nvidia"
	BusID "PCI:1:0:0" #Tried without, same result
EndSection

Section "Device"
	# Edit the BusID with the location of your graphics card
	Identifier "nvidia1"
	Driver "nvidia"
	BusID "PCI:1:0:0"
	Screen 1
EndSection

Section "Screen"
	Identifier "Screen0"
	Device "nvidia0"
	Monitor "Monitor0"
	DefaultDepth 24
	SubSection "Display"
		Depth 24
		Modes "1280x1024" "1024x768" "800x600" "640x480"
	EndSubSection
EndSection

Section "Screen"
	Identifier "Screen1"
	Device "nvidia1"
	Monitor "Monitor1"
	DefaultDepth 24
	SubSection "Display"
		Depth 24
		Modes "1280x1024" "1024x768" "800x600" "640x480"
	EndSubSection
EndSection
Attached Files
File Type: txt Xorg.0.log.txt (27.1 KB, 200 views)
File Type: txt xorg.conf.txt (3.4 KB, 345 views)
sergdarkstar is offline   Reply With Quote