View Single Post
Old 12-20-02, 04:57 PM   #2
wsanders
Registered User
 
Join Date: Dec 2002
Posts: 3
Default 4180 GLX makefile warning!

(This is RH7.3 with gcc 2.96)

OK now I see something, the NVIDIA_kernel-1.0-4180 tarball attempts to produce a module named nv-kernel.o and the NVIDIA_GLX-1.0-4180 tarball has a precompiled module nvidia_drv.o. Yuk.

Warning: The first thing the GLX makefile does is wipe out your existing drivers without backing them up:

$ make
Removing all old and conflicting files!
rm -f //usr/lib64/libGL.*
rm -f //usr/lib64/libGLcore.*
rm -f //usr/X11R6/lib64/libGL.*
...

This package appears to have a precompiled nvidia_drv.o:

./X11R6/lib/modules/drivers:
total 600
-rwx------ 1 wsanders wsanders 609032 Dec 4 09:01 nvidia_drv.o*

I'm assuming this is the same module that the NVIDIA_kernel-1.0-4180 tarball eventually is supposed to produce, but is named nv-linux.o, instead?

Comment in GLtarball Makefile:

# this is pretty brain-dead, but should be good enough to get started

Obviously!

The kernel source make bombs off with

cc1: Invalid option `cmodel=kernel'

so I'm guessing i need gcc 3-something anyway to buildthis.
wsanders is offline   Reply With Quote