View Single Post
Old 12-26-02, 03:27 AM   #1
winghong
Registered User
 
Join Date: Dec 2002
Posts: 4
Question A Newbie's Question

My linux is Slackware 8.0. When I install the drivers, errors occur.

root@polaris:/# rpm -ivh /usr/src/rpm/RPMS/i386/NVIDIA_kernel-1.0-4191.i386.rpm
error: failed dependencies:
kernel >= 2.2.0 is needed by NVIDIA_kernel-1.0-4191
rpm >= 3.0.4 is needed by NVIDIA_kernel-1.0-4191
/bin/sh is needed by NVIDIA_kernel-1.0-4191
/bin/sh is needed by NVIDIA_kernel-1.0-4191
/bin/sh is needed by NVIDIA_kernel-1.0-4191

root@polaris:/# rpm -ivh /usr/src/rpm/RPMS/i386/NVIDIA_GLX-1.0-4191.i386.rpm
error: failed dependencies:
XFree86 >= 4.0.1 is needed by NVIDIA_GLX-1.0-4191
NVIDIA_kernel is needed by NVIDIA_GLX-1.0-4191
kernel > 2.2.0 is needed by NVIDIA_GLX-1.0-4191
/bin/sh is needed by NVIDIA_GLX-1.0-4191
/bin/sh is needed by NVIDIA_GLX-1.0-4191
/bin/sh is needed by NVIDIA_GLX-1.0-4191
ld-linux.so.2 is needed by NVIDIA_GLX-1.0-4191
libX11.so.6 is needed by NVIDIA_GLX-1.0-4191
libXext.so.6 is needed by NVIDIA_GLX-1.0-4191
libc.so.6 is needed by NVIDIA_GLX-1.0-4191
libdl.so.2 is needed by NVIDIA_GLX-1.0-4191
libm.so.6 is needed by NVIDIA_GLX-1.0-4191
libc.so.6(GLIBC_2.0) is needed by NVIDIA_GLX-1.0-4191
libdl.so.2(GLIBC_2.0) is needed by NVIDIA_GLX-1.0-4191
libdl.so.2(GLIBC_2.1) is needed by NVIDIA_GLX-1.0-4191

However, I have checked that my configuration is kernel 2.2.19, rpm 4.0.2 and /bin/sh is found.
winghong is offline   Reply With Quote