View Single Post
Old 03-16-05, 10:42 PM   #1
wmauer
Registered User
 
Join Date: Mar 2005
Posts: 2
Default Upgrading to 7167 in Xandros

I'm running Xandros 3.01 OCE (Open Circulation Edition) and I have an FX5900XT. Upon loading the OS, it correctly detects and installs the 6629 drivers. However, this is the unpatched version, so Half Life 2 runs very poorly.

After reading about the 40MB VRAM issue with this driver, I headed over to get 7167. After compiling my kernel, and running the installer, the module fails to pass the runtime sanity check, and susequently causes kdm not to start. I had to edit the xorg.conf file, and use the default nv drivers to be able to post this. Here is the error from nvidia-installer:

-> Running runtime sanity check:
ERROR: The runtime configuration check failed for library
'libnvidia-tls.so.1.0.7167' (expected:
'/usr/lib/tls/libnvidia-tls.so.1', found:
'/usr/lib/nvidia/tls/libnvidia-tls.so.1'). The most likely reason for
this is that conflicting OpenGL libraries are installed in a location
not inspected by nvidia-installer. Please be sure you have uninstalled
any third-party OpenGL and third-party graphics driver packages.
-> done.

Oddly enough, the file it is "expecting" is there, and the file it "found" is not. Could this be a symlink issue, and if so, how can I work around it?

This occurs even after I have rebuilt the machine, and tried to upgrade the driver with just a vanilla install of the OS. If I try to roll back to 6629, the same problem occurs, with the same message.

I have included a copy of my nvidia-bug-report.log which was generated after I got kdm working again. If any other information is needed, I will gladly provide it. Thanks in advance!

Wes
Attached Files
File Type: txt nvidia-bug-report.txt (77.8 KB, 187 views)
wmauer is offline   Reply With Quote