View Single Post
Old 08-07-02, 02:12 AM   #2
FlyingDutchMan
Guest
 
Posts: n/a
Default Re: RH7.2 (2.4.9-34) install + src.rpm problem

Quote:
Originally posted by FlyingDutchMan
I have some problems in installing the NVIDIA drivers. I use RH7.2 with latest RH kernel-update (2.4.9-34). Based on NVchooser I selected;
* NVIDIA_GLX-1.0-2960.i386.rpm
* NVIDIA_kernel-1.0-2960.rh72up.i686.rpm
When checking on dependencies, I get following error message;

Found 0 source and 2 binary packages
Dependency problem:
kernel is needed by NVIDIA_kernel-1.0-02960.rh72up
I have not been able to tackle this problem, but I assume that it is related to the newer kernel I have installed (2.4.9-34).

Quote:
Originally posted by FlyingDutchMan continued with
I assumed this to be related to my new kernel, so I thought to give it a try by installing the NVIDIA kernel via the source rpm's. So I downloaded;
* NVIDIA_kernel-1.0-2960.src.rpm
Following the instruction in the readme file, I enter;

rpm --rebuild NVIDIA_kernel-1.0-2960.src.rpm

Then I get the error message;

NVIDIA_kernel-1.0-2960.src.rpm: No such file or directory
For this section there is only one abbreviation applying to me; RTFM. On advise of somebody in another post I printed the README.txt and found the answer in it; I needed to install the rpm-build package. After having done that I got my system trying to rebuild, but with error-messages. One of the error messages was # error Modules should never use kernel-headers system headers. This was the next point in the README.txt on which the solution is to install the kernel-source. And that tackled my installation problems. Hopefully my descriptions solve problems for others.

Apologies for taking your time without having read the README-file.
Frank
  Reply With Quote