View Single Post
Old 04-01-05, 10:50 AM   #1
warb
Registered User
 
Join Date: Jan 2003
Location: NJ
Posts: 2
Default Getting nvidia driver to load on boot

I am having trouble getting the nvidia driver to load on boot.

I am running Fedora Core 3, kernel 2.6.11.5 (compiled by me).

I have installed NVIDIA-Linux-x86-1.0-7167-pkg1

I can get the driver to load if after a boot I do a modprobe nvidia.

Some program keeps putting nv in my xorg.conf file when the boot fails.

Any Ideas?

Thanks.

attached nvidia-bug-report.log (with txt appened to have it accepted)

before last reboot I did a cp -a /dev/nvidia* /etc/udev/devices

excerpt from messages:
Apr 1 15:00:05 mars kernel: Vendor: SEAGATE Model: ST336753LW Rev: 0003
Apr 1 15:00:05 mars cups-config-daemon: cups-config-daemon startup succeeded
Apr 1 15:00:05 mars kernel: Type: Direct-Access ANSI SCSI revision: 03
Apr 1 15:00:06 mars haldaemon: haldaemon startup succeeded
Apr 1 15:00:06 mars kernel: scsi0:A:1:0: Tagged Queuing enabled. Depth 4
Apr 1 15:00:06 mars fstab-sync[3983]: removed all generated mount points
Apr 1 15:00:06 mars nvidia: Checking for nvidia kernel module failed
Apr 1 15:00:07 mars kernel: SCSI device sdb: 71687372 512-byte hdwr sectors (36704 MB)
Apr 1 15:00:07 mars kernel: SCSI device sdb: drive cache: write back
Apr 1 15:00:07 mars kernel: SCSI device sdb: 71687372 512-byte hdwr sectors (36704 MB)
Apr 1 15:00:07 mars fstab-sync[4039]: added mount point /media/cdrecorder for /dev/hdc
Apr 1 15:00:07 mars nvidia: Disabling nvidia driver succeeded
Apr 1 15:00:07 mars kernel: SCSI device sdb: drive cache: write back
Apr 1 15:00:07 mars kernel: sdb: sdb1
Apr 1 15:00:07 mars kernel: Attached scsi disk sdb at scsi0, channel 0, id 1, lun 0
Apr 1 15:00:07 mars kernel: scsi1 : Adaptec AIC79XX PCI-X SCSI HBA DRIVER, Rev 1.3.11

udev :
root@mars log]# ls -l /etc/udev/devices/nv*
crw------- 1 warb root 195, 255 Feb 15 12:15 /etc/udev/devices/nvidia
crw------- 1 warb root 195, 0 Apr 1 11:14 /etc/udev/devices/nvidia0
crw------- 1 warb root 195, 1 Apr 1 11:14 /etc/udev/devices/nvidia1
crw------- 1 warb root 195, 2 Apr 1 11:14 /etc/udev/devices/nvidia2
crw------- 1 warb root 195, 3 Apr 1 11:14 /etc/udev/devices/nvidia3
crw------- 1 warb root 195, 4 Apr 1 11:14 /etc/udev/devices/nvidia4
crw------- 1 warb root 195, 5 Apr 1 11:14 /etc/udev/devices/nvidia5
crw------- 1 warb root 195, 6 Apr 1 11:14 /etc/udev/devices/nvidia6
crw------- 1 warb root 195, 7 Apr 1 11:14 /etc/udev/devices/nvidia7
crw------- 1 warb root 195, 255 Apr 1 11:14 /etc/udev/devices/nvidiactl
[root@mars log]#
Attached Files
File Type: txt nvidia-bug-report.log.txt (95.2 KB, 161 views)
File Type: txt Xorg.0.log.txt (41.0 KB, 177 views)

Last edited by warb; 04-01-05 at 03:22 PM. Reason: more info
warb is offline   Reply With Quote