View Single Post
Old 04-06-05, 11:02 AM   #1
wraiden
Registered User
 
Join Date: Jun 2004
Posts: 3
Exclamation Patch for 1.0-7174 and linux-2.6.12-rc1-mm3 or higher mm kernels

The removement of the class simple API from Greg K-Hīs [1] driver tree [ will be soon in vanilla also ] renders nvidia driver interaction with udev useless on 2.6.12-rc1-mm3 or higher mm kernels.

DONīT patch your driver for other kernels or if your dev isn't udev managed.

To get rid of manual device creation after each startup patch your kernel tree [ patch 1 ] and your driver tree [ patch 2 ]

Read the Patch headers for more details.

have fun
[ and excuse my bad english ]

[1] http://marc.theaimsgroup.com/?l=linu...4768314104&w=2
Attached Files
File Type: txt export-class-api_kernel.patch.txt (1.3 KB, 255 views)
File Type: txt class-api_nvidia.patch.txt (3.6 KB, 239 views)

Last edited by wraiden; 04-06-05 at 11:05 AM. Reason: note the patch descriptions
wraiden is offline   Reply With Quote