View Single Post
Old 04-23-05, 05:23 PM   #120
bugfood
Registered User
 
Join Date: May 2003
Posts: 19
Default Re: nVidia Linux Driver support for mobile video cards (Geforce* Go)...

Quote:
Originally Posted by GerbilSoft
I don't know how, but I fixed it! The solution is to use gtf to generate a modeline, but change the "+Vsync" at the end to "-Vsync". I currently have a working 1400x1050 modeline with no black bar. (Using lower resolutions results in a black bar, but I'll fix those later.)

Code:
Original: Modeline "1400x1050"  122.61  1400 1488 1640 1880  1050 1051 1054 1087  -HSync +Vsync
Working: Modeline "1400x1050"  122.61  1400 1488 1640 1880  1050 1051 1054 1087  -HSync -Vsync
Thank you very much! That gives me a working modeline, finally. I'll post details of all that was necessary in case it benefits anyone else.

Toshiba 5105-S501, with GeForce4 440 Go and 1400x1050 display
Linux 2.6.12-rc2-mm1
XFree86 4.3.0.1
nvidia driver version 7174

No parameters are needed for the kernel module. Just 'modprobe nvidia'.

At a terminal use gtf to make a modeline. For a 1400x1050 display, run:
$ gtf 1400 1050 60
The third argument should, as far as I know, be 60 for any laptop.

Open up the XF86Config-4 file.
In the "Device" section, add 'Option "IgnoreEDID" "1"'.
In the "Monitor" section, set VertRefresh to 60.
Your HorizSync may vary; I'm using 30-67, though I don't actually know what the real values are.
Now copy the modeline you just made with gtf into the "Monitor" section, and change the last parameter from '+Vsync' to '-Vsync'.
In the "Screen" section, your Modes line should reference the name of the modeline you added. For example, 'Modes "1400x1050_60.00'.

Save the file and run X. There should be no black bar, and the resolution should be 1400x1050.

For what it's worth, the Windows driver has the same problem on my laptop. Actually, version 7189 refuses to even install unless I get a driver and modded INF from http://www.laptopvideo2go.com/.
bugfood is offline   Reply With Quote