View Single Post
Old 08-07-02, 03:03 PM   #1
jinksed
Guest
 
Posts: n/a
Default X freezes when agp 4x is enabled

I've had this problem for a while. I have an nvidia geforce 2 mx 400 64mb with tv out that locks when i try using 4x agp. everything works fine if i use 2x. i have an asus tusl2-c mobo(i815 chipset). im using the latest drivers in slackware 8.1 2.4.18.

bash-2.05a# lspci
00:00.0 Host bridge: Intel Corp. 82815 815 Chipset Host Bridge and Memory Controller Hub (rev 04)
00:01.0 PCI bridge: Intel Corp. 82815 815 Chipset AGP Bridge (rev 04)
00:1e.0 PCI bridge: Intel Corp. 82801BA/CA PCI Bridge (rev 02)
00:1f.0 ISA bridge: Intel Corp. 82801BA ISA Bridge (LPC) (rev 02)
00:1f.1 IDE interface: Intel Corp. 82801BA IDE U100 (rev 02)
00:1f.2 USB Controller: Intel Corp. 82801BA/BAM USB (Hub #1) (rev 02)
00:1f.3 SMBus: Intel Corp. 82801BA/BAM SMBus (rev 02)
00:1f.4 USB Controller: Intel Corp. 82801BA/BAM USB (Hub #2) (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation NV11 [GeForce2 MX] (rev b2)
02:0a.0 Multimedia audio controller: Ensoniq ES1371 [AudioPCI-97] (rev 07)
02:0b.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C (rev 10)
02:0c.0 Multimedia video controller: Brooktree Corporation Bt878 Video Capture (rev 02)
02:0c.1 Multimedia controller: Brooktree Corporation Bt878 Audio Capture (rev 02)
02:0d.0 Ethernet controller: D-Link System Inc RTL8139 Ethernet (rev 10)
bash-2.05a#


cat /proc/drvier/nvidia/apg:

Status: Enabled
Driver: AGPGART
AGP Rate: 2x
Fast Writes: Disabled
SBA: Disabled

bash-2.05a# cat card
Fast Writes: Supported
SBA: Not Supported
AGP Rates: 4x 2x 1x
Registers: 0x1f000017:0x1f000102
bash-2.05a#

bash-2.05a# cat host-bridge
Host Bridge: Intel i815
Fast Writes: Not Supported
SBA: Supported
AGP Rates: 4x 2x 1x
Registers: 0x1f000207:0x00000102
bash-2.05a#
  Reply With Quote