View Single Post
Old 06-02-05, 05:12 AM   #10
LeDmagNeT
Registered User
 
Join Date: May 2005
Posts: 5
Default Re: Nvidia wont go back to 1600x1200 on FC3

Quote:
Originally Posted by Pixie
It's the normal display on my laptop. Dell 1600x1200 display panel should be correct. I'll mess around with hsync and vrefresh and see if I can get it right. Thanks for the help.
You have the Dell C840 with the Samsung SEC3250 1600x1200 LCD which is believed to report incorrect EDID data.
I also have a c840 with that LCD and have the exact same problem. Many other users of this LCD screen are reporting the same probs.
This problem is also evident using WinXP and the fix is the same in concept.
You basically have to override the reported EDID data. Hence the requirement of the Option "IgnoreEDID" in your "Device" section.
Unfortunately you will need a modeline or modes to specify timings as you are overriding the EDID after all, and it seems the standard Vesa timings that come with xorg don't work for us. Well, that's how I understand it anyway. Someone please correct me if I'm wrong.

So, in short you need:
Option "IgnoreEDID" in your "Device" section
and the following in your "Monitor" section:
HorizSync 75
VertRefresh 60
Modeline "1600x1200" 160.96 1600 1704 1880 2160 1200 1201 1204 1242 -HSync -Vsync

That's the only fix I've managed to find that works so far.

I am using this config on my c840 and it works well under kubuntu.

Good luck.
LeDmagNeT is offline   Reply With Quote