View Single Post
Old 01-28-03, 05:20 PM   #6
LordMorgul
Electrical Engineer
 
LordMorgul's Avatar
 
Join Date: Dec 2002
Location: San Luis Obispo, CA
Posts: 872
Talking High quality sound a killer :D

I've recently been searching for performance in UT2k3 as well, for reference my system:

2.0A P4 512 ECC RDRAM
Creative Audigy Gamer
GeForce 4 Ti4400
Running RedHat 8.0 (2.4.19 cust)
and the infamous x4191 drivers

The short story for those who want better fps:

Disable High quality sound, or all sound, and check your fps. Running low quality sound I average ~45 fps everywhere at 1600x1200 max quality settings. Yes, it still spikes low ~20 in areas, the engine doesn't seem to be perfect in handling the map designs given.

How do you disable high quality sound?
Edit your engine config file at: ~/.ut2003/System/UT2003.ini

under the heading...
[ALAudio.ALAudioSubsystem]
...
LowQualitySound=True

you may also wish to adjust settings here.
[OpenGLDrv.OpenGLRenderDevice]

I was running extremely low fps ~15 and lower with typically low fps areas running up ~45. I found that this behavior was independent of my graphics settings entirely (640x480 low = same fps as 1600x1200 maxed). That means its not graphics hardware related.

Performance charting cpu / memory / swapping etc shows the system is not under heavy load, ~60% cpu load with 1~2 processes waiting for cpu time (vmstat).

Now sound running low, the system keeps up ~45 fps with intense settings, and UT2k3 looks great
LordMorgul is offline   Reply With Quote