View Single Post
Old 07-29-05, 05:53 PM   #6
mspiegle
Registered User
 
Join Date: Nov 2004
Posts: 12
Default Re: VT crash with tv-out

I am having the same problem. I finally got this thing configured EXACTLY how I want it to act. When I have my laptop connected to a TV (SVIDEO), it is separate from what is on my laptop's LCD. The only way to launch apps on the TV is to specify DISPLAY=:0.1. It does do extensions/cloning, or anything wierd like that. When my laptop is not connected to the TV, it acts just like any other computer (the mouse is confined to the LCD screen only). My problem is that whenever I logout of Xorg, or switch to a virtual terminal - it hard locks.

Asus Z71V Laptop
Geforce 6600 PCI-EXPRESS 128MB
Intel(R) Pentium(R) M processor 2.00GHz

Gentoo: 2005.0
Xorg: 6.8.2-r2
Nvidia: 7667
Kernel: 2.6.12-gentoo-r4

xorg.conf:

Section "Files"
RgbPath "/usr/lib/X11/rgb"
ModulePath "/usr/lib/modules"
FontPath "/usr/share/fonts/misc/"
FontPath "/usr/share/fonts/TTF/"
FontPath "/usr/share/fonts/Type1/"
FontPath "/usr/share/fonts/CID/"
FontPath "/usr/share/fonts/75dpi/"
FontPath "/usr/share/fonts/100dpi/"
EndSection

Section "Module"
Load "glx"
Load "record"
Load "extmod"
Load "dbe"
Load "xtrap"
Load "freetype"
Load "type1"
Load "synaptics"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Dev Name" "Logitech USB Receiver"
Option "Device" "/dev/input/mice"
Option "Buttons" "12"
Option "ZAxisMapping" "11 12"
Option "Resolution" "800"
EndSection

Section "InputDevice"
Identifier "Synaptics Mouse"
Driver "synaptics"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "LeftEdge" "1700"
Option "RightEdge" "5300"
Option "TopEdge" "1700"
Option "BottomEdge" "4200"
Option "FingerLow" "25"
Option "FingerHigh" "30"
Option "MaxTapTime" "180"
Option "MaxTapMove" "220"
Option "VertScrollDelta" "100"
Option "MinSpeed" "0.09"
Option "MaxSpeed" "0.18"
Option "AccelFactor" "0.0015"
Option "SHMConfig" "on"
EndSection

Section "Monitor"
Identifier "Monitor0"
VertRefresh 60
HorizSync 30-67
Modeline "1680x1050_60.00" 147.14 1680 1784 1968 2256 1050 1051 1054 1087 -HSync -Vsync
EndSection

Section "Monitor"
Identifier "Monitor1"
VertRefresh 60
HorizSync 30-50
EndSection

Section "Device"
Identifier "nvidia0"
Option "DigitalVibrance" "48"
Option "NoLogo" "true"
Option "SWcursor" "false"
Option "HWcursor" "true"
Option "NvAGP" "1"
Option "IgnoreEDID" "true"
Option "RenderAccel" "true"
Option "Coolbits" "3"
Driver "nvidia"
BusID "PCI:1:0:0"
Screen 0
EndSection

Section "Device"
Identifier "nvidia1"
Option "TVStandard" "NTSC-M"
Option "TVOutFormat" "SVIDEO"
Option "ConnectedMonitor" "TV"
Driver "nvidia"
BusId "PCI:1:0:0"
Screen 1
EndSection

Section "Screen"
Identifier "Screen0"
Device "nvidia0"
Monitor "Monitor0"
DefaultDepth 24
Subsection "Display"
Depth 24
Modes "1680x1050_60.00"
EndSubsection
EndSection

Section "Screen"
Identifier "Screen1"
Device "nvidia1"
Monitor "Monitor1"
DefaultDepth 24
Subsection "Display"
Depth 24
Modes "800x600"
EndSubsection
EndSection

Section "ServerLayout"
Identifier "default"
Screen 0 "Screen0"
Screen 1 "Screen1"
InputDevice "Synaptics Mouse" "Alwayscore"
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection
mspiegle is offline   Reply With Quote