View Single Post
Old 01-31-03, 05:33 AM   #9
Jeremy Bear
Registered User
Join Date: Sep 2002
Location: Gloucestershire, UK
Posts: 14

Try modifying your XF86Config as follows: (works fine on my Tosh SatPro 6100 with same NV chip)

Make a backup of your XF86 Config (/etc/X11/XF86Config) then modify it as follows:

"Module" section:

1. Remove the line> Load "dri"
2. Remove the line> Load "GLcore"
3. Ensure you have the line> Load "glx"

"Monitor" section:

For a basic setup, all you need is:

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Toshiba 6100 LCD Display"
HorizSync 31.5 - 150
VertRefresh 50.0 - 100
Modeline "1024x768" 97.40 1024 1072 1192 1416 768 768 771 809
Option "ddc" "off"

"Device" section:

It's very important that the Driver line is changed from "nv" or "vesa" to "nvidia". Also, remember to check the amount of video RAM you have, and decide whether you want BackingStore on or off. (Must be off if you are using Win4Lin).

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "NVIDIA"
BoardName "NVIDIA GeForce 4 420 Go"
VideoRam 32768
Option "BackingStore" "Off"

"Screen" section:

You can add more modes as required, but note that each must have a valid modeline in the "Monitor" section. The "Virtual" line disables the display panning that would otherwise occur by default, and forces the driver to display everything within the confines of the screen dimensions.

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Modes "1024x768"
SubSection "Display"
Depth 24
Modes "1024x768"
Virtual 1024 768

Assuming all is well, you may notice a black vertical line at the right hand side of the screen. To get rid of this, add the following line to /etc/modules.conf :

options nvidia NVreg_SoftEDIDs=0 NVreg_Mobile=2

and re-boot.

Good luck!


Last edited by Jeremy Bear; 01-31-03 at 05:36 AM.
Jeremy Bear is offline   Reply With Quote