View Single Post
Old 08-27-05, 11:09 PM   #3
tomkweb
Registered User
 
Join Date: Aug 2005
Posts: 2
Default Re: API mismatch: 2.6.12-1.1398_FC4 x86_64

Thanks Thunderbird! With your help I finally have 2 graphics cards working with NVIDIA drivers on FC4 AMD64.
1. cleanup old: # yum remove nvidia-graphics*
2. install latest: from init 3, # sh NVIDIA-Linux-x86_64-1.0-7676-pkg2.run
3. BUT: # modprobe nvidia still failed until I found:
/etc/modprobe.conf should have an entry "alias char-major-195* nvidia".
If the entry is "alias char-major-195* nvidia-1_0-7667", drop the -1_0-7667.
If there is a entry "alias nvidia nvidia-1_0-7667", remove it.
*If you want some speed boosts from you GPU this is a little trick that helpes.
Open the /etc/modprobe.conf file, under the line "alias char-major-195*" add this line.
"options nvidia NVreg_EnableAGPSBA=1 NVreg_EnableAGPFW=1 NVreg_ReqAGPRate=8"
This turns on SideBand Addressing, FastWrites, and AGPRate x8.
4. initial display setup: # system-config-display
5. # vi /etc/X11/xorg.conf and change both
Driver "nv" with Driver "nvidia"
6. With 2 graphics cards(one for monitor, the other for projector), this failed until I added "BOTH" BusID (AGP card=PCI:1:0:0, PCI card=PCI:2:7:0 for me) to the Device sections:
Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard Vendor"
BoardName "NVIDIA GeForce 4 MX (generic)"
BusID "PCI:1:0:0"
EndSection
Section "Device"
Identifier "Videocard1"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 2 MX (generic)"
BusID "PCI:2:7:0"
EndSection

-Tom
tomkweb is offline   Reply With Quote