View Single Post
Old 02-02-03, 03:41 PM   #2
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Well, if the default drivers only give you AGP 1x, then that's because they think your chipset isn't stable at 2x or 4x.

If you want to prove them wrong, then you're going to have to install the NVIDIA_kernel package from .tar.gz. Unpack it (with tar xvzf or similar), and edit the os-registry.c file after it's decompressed. Don't change the NVreg_ReqAGPRate setting in there (well... you can if you want to, but if you do change it here rather than using a module param, you'll never be able to use any other AGP rate...), but do, near the bottom of the file, get rid of the two underscores in the string.

For example, the last few lines of my os-registry.c look like this:

Code:
nv_parm_t nv_parms[] = {
    { NULL, "__VideoMemoryTypeOverride",  &NVreg_VideoMemoryTypeOverride  },
    { NULL, "ResmanDebugLevel",           &NVreg_ResmanDebugLevel         },
    { NULL, "EnableVia4x",                &NVreg_EnableVia4x              },
    { NULL, "EnableALiAGP",               &NVreg_EnableALiAGP             },
    { NULL, "UpdateKernelAGP",            &NVreg_UpdateKernelAGP          },
    { NULL, "__ReqAGPRate",               &NVreg_ReqAGPRate               },
    { NULL, "EnableAGPSBA",               &NVreg_EnableAGPSBA             },
    { NULL, "EnableAGPFW",                &NVreg_EnableAGPFW              },
    { NULL, "SoftEDIDs",                  &NVreg_SoftEDIDs                },
    { NULL, "Mobile",                     &NVreg_Mobile                   },
    { NULL, "FlatPanelMode",              &NVreg_FlatPanelMode            },
    { NULL, NULL,                         NULL                            }
};
so I would change it to look like this:

Code:
nv_parm_t nv_parms[] = {
    { NULL, "__VideoMemoryTypeOverride",  &NVreg_VideoMemoryTypeOverride  },
    { NULL, "ResmanDebugLevel",           &NVreg_ResmanDebugLevel         },
    { NULL, "EnableVia4x",                &NVreg_EnableVia4x              },
    { NULL, "EnableALiAGP",               &NVreg_EnableALiAGP             },
    { NULL, "UpdateKernelAGP",            &NVreg_UpdateKernelAGP          },
    { NULL, "ReqAGPRate",                 &NVreg_ReqAGPRate               },
    { NULL, "EnableAGPSBA",               &NVreg_EnableAGPSBA             },
    { NULL, "EnableAGPFW",                &NVreg_EnableAGPFW              },
    { NULL, "SoftEDIDs",                  &NVreg_SoftEDIDs                },
    { NULL, "Mobile",                     &NVreg_Mobile                   },
    { NULL, "FlatPanelMode",              &NVreg_FlatPanelMode            },
    { NULL, NULL,                         NULL                            }
};
Notice how there are now no __'s in front of ReqAGPRate? That's the way it should be. ReqAGPRate is disabled by default -- the reason is detailed up by the setting itself in os-registry.c.

Once you change that, you can just make the driver, and then try passing it the higher ReqAGPRate parameter. If it works, and if your system is stable, then continue using it. If not, you're going to have to revert that change back.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote