Thread: debian xserver
View Single Post
Old 02-05-03, 12:29 AM   #2
KingFish
Registered User
 
Join Date: Jan 2003
Posts: 10
Default

Heh, I know how you must feel!
I started with Linux and Debian a few month ago and the first steps where so damn hard... Well, hope I'm able to share my experience with you:

In my eyes your problem is, you're using XF86's nvidia driver module called 'nv'. It never worked for me! You have to install the ' nvidia ' kernel module (unfortunately you need a custom built kernel for this) and the ' nvidia glx module '.
All of it is already included in Debian Woddy, hence it's very out of date (yes, sue me, I hate Debian's "ultra-mega-stable" version, big supporter of the "nearly-everytime-crashing-0%-unstable" version).
Now do the following:
start dselect and select 'kernel-source-2.4.18' 'kernel-package' 'nvidia-kernel-src' and 'nvidia-glx-src'. After installation of all of them, go to /usr/src and unpack 'kernel-source-2.4.18.tar.bzip2' & 'nvidia-kernel-src.tar.gz' (hope I recall these filenames correctly)
Now go into the kernel-source directory and type a ' make menuconfig ' to compile a little helper tool for the kernel configuration. If it fails, check you've installed 'libncurses-dev'. Once it loads take your time and read all of the available help text. Configure it for your needs and save it. now type a ' make-kpkg --revision=MYBOX.1.0.0 kernel_image ' and your customized kernel should been build. Takes a while.
After that a newly created .deb lies in /usr/src. You're able to install it with ' dpkg -i kernel-image-2.4.18_2.4.18.MYBOX.1.0.0.deb ' (or similar) update your boot block on hdd with lilo or your boot floppy, whichever your use, and boot into your new kernel.
Go again /usr/src/kernel-source-2.4.18 and now type a ' make-kpkg modules_image '. This will compile the nvidia kernel module. By either sure you've extracted it (don't worry it goes automatically in the correct folder (/usr/src/modules/nvidia-kernel-src) ) and that you're connected to the internet, because it will download the nvidia source for the module and compile it. After that (you guessed correctly) a new deb recides in /usr/src. Install it with ' dpkg -i nvidia-kernel-module_1.0. ... '
Everything should work fine till now. Try to load the nvidia kernel module with ' insmod NVdriver ' with an nvidia driver prior to 4192 or ' insmod nvidia ' on 4192. A stupid message might apear about the now tainted kernel, ingore it. Try its loaded with an ' lsmod '. You may want to place NVdriver/nvidia in /etc/modules.conf to load it at startup, but thats optional since its autoload-able. Fine, survived another part
Go again to /usr/src and unpack (if you haven't done it yet) the nvidia-glx-src package and cd in the new directory. A 'dpkg-buildpackage -b' will compile it. Install the new deb (again in /usr/src). Now do a ' dpkg-reconfigure xserver-xfree86 ' and from the driver list select now 'nvidia' not 'nv'. Don't forget to change the XF86 server module settings: disable GLcore and dri while you're enabling GLX. before you are able to start do a ' adduser <your normal login/not root!> video ' (you need some extra privilegues in order to use hardware accelaration) and now login with this user and type ' startx '. If everything above worked, it should just work fine, hence you now have XV hardware accelaration and OpenGL and everything else.

Well, this was it (hope I did't miss any important task). If anything is unclear or somehow not understandable, ask me, I'll try to explain better. Also try a search for other tutorials on the net for the procedure, should give plenty.

Have fun with your new linux box !

Bye
KingFish is offline   Reply With Quote