View Single Post
Old 02-06-03, 07:43 PM   #1
arsenius
Registered User
 
Join Date: Feb 2003
Posts: 3
Default X won't load due to GLX error? Reverting to old config file doesn't help!

Hi guys,
Having some trouble installing drivers obviously. I've tried installing from source, and from rpm on two machines, and I'm having the same problem on both. One card is a Geforce 4 and the other a Geforce 4 MX. Fresh installs of Redhat 8.0 psyche on each.

If I just leave the XF86config file the way it is, it works fine, and I can get into X, but obviously that is unaccelerated (which pretty much renders these machines useless, since we are using them for graphics at my work )

I'm installing the drivers exactly as it says in the README, and making only the changes it specifies. When I startx it errors out, giving me the following error:

Symbol __glXActiveScreens from module /usr/X11R6/lib/modules/extensions/libdri.a is unresolved!
Symbol __glXActiveScreens from module /usr/X11R6/lib/modules/extensions/libdri.a is unresolved!
(II) Setting vga for screen 0.
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension LBX
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(II) [GLX]: Initializing GLX extension

Fatal server error:
Caught signal 4. Server aborting

Changing back to the old config file DOES NOT fix the problem, nor does commenting out the 'load "glx"' line in modules. I also have tried commenting out the 'Section "DRI"' part as I also saw that suggested on these forums.

I did a search on this forum for "[GLX]: Initializing GLX extension", and didn't come up with anything (aside: why does the search function not let quotes designate a string to be searched for? it just parses it up as though they weren't even there) The only thing I can think of at this point is that it is a bug with redhat 8. I use debian on my personal machine, and haven't had problems like this w/ the drivers.

My XF86Config is below, and I am attaching my XFree86 log as well.

thanks in advance


# File generated by anaconda.

Section "ServerLayout"
Identifier "Anaconda Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Mouse1" "SendCoreEvents"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# The location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.

RgbPath "/usr/X11R6/lib/X11/rgb"

# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.

FontPath "unix/:7100"

EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
# Load "dri"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"

# Option "AutoRepeat" "500 5"

# when using XQUEUE, comment out the above line, and uncomment the
# following line
# Option "Protocol" "Xqueue"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"

# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"

# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
#Option "XkbVariant" ""
#Option "XkbOptions" ""
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection


Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Device" "/dev/input/mice"
Option "Protocol" "IMPS/2"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection


Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
HorizSync 30.0-96.0
VertRefresh 48.0-160.0
Option "dpms"


EndSection

Section "Device"
# no known options
Identifier "NVIDIA GeForce 4 (generic)"
# Driver "vesa"
Driver "nvidia"
VendorName "NVIDIA GeForce 4 (generic)"
BoardName "NVIDIA GeForce 4 (generic)"

#BusID
EndSection

Section "Screen"
Identifier "Screen0"
Device "NVIDIA GeForce 4 (generic)"
Monitor "Monitor0"
DefaultDepth 16

Subsection "Display"
Depth 16
Modes "1600x1200" "1400x1050" "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubsection

EndSection

#Section "DRI"
# Mode 0666
#EndSection
Attached Files
File Type: txt xfree86.0.txt (48.7 KB, 141 views)
arsenius is offline   Reply With Quote