View Single Post
Old 02-07-03, 02:07 AM   #3
junkieclown
Helium Abuser
 
junkieclown's Avatar
 
Join Date: Nov 2002
Location: Summers in Rangoon, but mostly in my evil underground lair and Volcano laboratory. though
Posts: 45
Default

The problem you're experiencing is that ti4200 cards are too new for the version of XFree86 bundled with your distribution to recognize. X can't probe the monitor to find out its capabilities, so unless your exact model is in the list of monitors redhat-config-xfree86 knows about you'll probably get a horrid looking display as the program defaults to safe values.

I could help you set up your card, but you have offended a Shaolin temple and you have offended Linux.
And you misspelled 'retarded' while trying to do it.

Well, on the other hand I recently badmouthed Nvidia for something that is not entirely their fault. So to atone for my own bad manners I will give you partial answers:

Find your monitor's manual or look up info on it at the manufacturer's website and discover its exact horizontal synch range and vertical refresh ranges.

run the program xf86config.
WHen asked about your monitor's characteristics select custom horizontal sync and put in exactly what you have discovered from the manual (for example 31.5 - 107 )
Don't put in guessed values.

Do the same when asked for vertical refresh ranges.

Select Nvidia Gforce 4 generic as your card. (This will setup your XF86Config to use the vesa driver )
set up screen resolutions for different color depths you might use: 24 bpp , 16bpp, 8bpp...
Let xf86config write out the new configuration file to the default location.

Now, having installed the Nvidia drivers and glx files, edit /etc/X11/XF86Config.

Change vesa driver to nvidia

Comment out anything about DRI --Nvidia doesn't use DRI and it will conflict.

Comment out anything about glcore
but leave 'load glx' alone.

If you have a USB mouse change whatever xf86config said your mouse is (/dev/mouse) to /dev/usbmouse.
eg; here's my Mouse section for my Logitech First / Pilot Wheel Mouse:

Section "InputDevice"

# Identifier and driver

Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/usbmouse"
Option "ZAxisMapping" "4 5"

Know what you have and the protocol it's going to use. IMPS/2 is an Intellimouse type mouse. If you dont' know you'll need to experiment. The last line is for mapping the wheel of a wheelmouse to X's ideas of buttons for up and down.

That should do it. As long as you gave accurate info about your monitors' characteristics you should have a X display that fills your monitor's screen.

It helps to be in runlevel 3 when you're doing this stuff.

Last edited by junkieclown; 02-07-03 at 02:15 AM.
junkieclown is offline   Reply With Quote