View Single Post
Old 02-07-03, 03:51 PM   #1
Registered User
Join Date: Feb 2003
Posts: 4
Default Can't get NVIDIA_kernel to work on Suse 8.0 Prof

I just checked this board because I didn't succeed to install the NVIDIA drivers for Suse 8.0 Prof. The solutions I found so far didn't help.

I have a Elsa Gladiac Ultra 64MB (GF2 Ultra) and a Nokia 445XiPLus Monitor.

First I tried to use Yast Online Update which got me nvidia drivers 3193 (or somthing). When I installed them I couldn't get my configuration to work. So I decided to download the drivers from nvidia 4191.
I installed them with rpm and I got the error message that some files are conflicting so I removed all of the drivers and installed it again using rpm. This worked.
The problem is that when I run 3Ddiag it always says that:

Tests for package "NVIDIA_GLX":
package ... done.
package files ... done.
Tests for package "NVIDIA_kernel":
package ... done.
package files ... failed!
================================================== ==============
Some file(s) of package NVIDIA_kernel are missing/modified:
S.5....T /lib/modules/2.4.18-4GB/video/nvidia.o

Consider to reinstall the package NVIDIA_kernel!
================================================== ==============

Tests for correct OpenGL libraries/GLX extensions:
Symbolic Links ... done.
/etc/sysconfig/3ddiag (SCRIPT_3D=switch2nvidia_glx) ... done.

Test for correct XFree86 version ... done.

Tests for XFree86 configuration:
Config File /etc/X11/XF86Config ... done.
Driver ... done.
Color Depth ... failed!
================================================== ==============
3D Hardware acceleration is not used. To use 3D
Hardware acceleration please specify one of these entries

DefaultDepth 16

in the Section "Screen" of your /etc/X11/XF86Config.
================================================== ==============
Extensions ... done.
Options ... done.

----------------------- NOTE -----------------------------------
If 3D hardware OpenGL configuration is not stable enough, you
should switch back to 'Mesa Software Rendering'. You can
verify this configuration with the command "3Ddiag --mesasoft".
----------------------- NOTE -----------------------------------

Checking GLU/glut runtime configuration:
GLU ... done (package mesaglu)
glut ... done (package mesaglut)

Any ideas how I can fix that? Yast incorrectly determines my gfx card as a Bladerunner Geforce 2 GTS and it doesn't allow me to set my resolution at 1600x1200/24Bit/88Hz. It only allows 1600x1200/16Bit/88Hz. It doesn't give me any other resolutions of frequencies. Using Sax2 it correctly determines my gfxcard as a GF2Ultra but I can't go beyond 1280x1024.
When I try to erase the installation with rpm -e it tells me that package is not installed, but when I try to install it again it says it is already installed.
I'm totally confused at what that means and I have no experience with rpm either, so I absolutely have no idea what to do to get my card working in all the modes it supports and with a working OpenGL environment.

Any help would be gladly appreciated!
sparhawk is offline   Reply With Quote