View Single Post
Old 02-07-03, 05:51 PM   #11
junkieclown
Helium Abuser
 
junkieclown's Avatar
 
Join Date: Nov 2002
Location: Summers in Rangoon, but mostly in my evil underground lair and Volcano laboratory. though
Posts: 45
Default

Here's a couple of things:

can you modprobe the nvidia module into the kernel?
lsmod first to see if nvidia is loaded. If not try to load it:
modprobe nvidia
If that doesn't work then there' s a problem with the Nvidia driver installation, and probably nothing further in this post will be useful until loading the nvidia module is straightened out.

If you can load the nvidia module, or if modprobe says nvidia is already loaded, then ...

Make sure the fontserver is running - and use chkconfig to have it started on boot. ::

service xfs restart
chkconfig --level 35 xfs on
-------------------------------------------------------
Edit /etc/X11/XF86Config and look for fontpath section (just below rgbpath in Section "FILES"

Comment out all the /usr/X11R6/lib/X11/font/ blahblah lines

change the fontpath section to look like this:

FontPath "unix/:7100"

# FontPath "/usr/X11R6/lib/X11/font/ blahblah"
# FontPath "/usr/X11R6/lib/X11/font/ blahblah"
etc...

(the FontPath "unix/:7100" line tells X to contact the fontserver for fonts)

This matter of the fontpath may not be so critical --it can be made to work either way-- but if you specify a font directory in XF86Config and it's not really there it's usual for the X server to bomb on start up. Probably best to change the FontPath to use xfs as described above.
The error message does say "File not found" - Fontpaths are files in the FILES section of the X config file --maybe this is the not found file the error message refers to.
Or it could be the mouse -- I'll get to that in a second.
-----------------------------------------
Now about the monitor section: you didn't say whether you found the manual to the monitor. Did you ?

Generic values offered in xf86config (eg; "a monitor that will do 1280x1024 at 60hz" ) will at least work , but produces a bad looking screen. If you know the ranges for certain you will get all the performance your monitor can give.

--------------------------------------------------

Now the mouse. This looks like it could be a problem that might produce the "FIle not found " error you see in your console.

Is your mouse USB and hooked up to a usb port?
Is it an Intellimouse?

Please feel free to post every little descriptive marking you can find on the mouse- the bottom of the mouse or the box.

Now about the missing file. Do you have a file named 'usbmouse' in /dev ?
That's how usb mice are set up in RH8, but looking at a RH7.2 server around here, I don't see any such /dev/usbmouse. I doubt you have one.

Saying "use /dev/usbmouse " was a bit of bad advice on my part. There is a difference in the way USB peripherals are handled between RH7 and RH8 and I'm not sure exactly how to refer to the mouse.

If you really have a USB mouse , you'll need to edit XF86Config so that the location /dev/usbmouse is changed to some usbmouse device file that actually exists like /dev/input/mice

or to create a symbolic link in /dev to that existing device file.
eg: ln -s /dev/input/mice /dev/usbmouse
and then keep the reference to usbmouse in the X config file. That may not work....

Once you're done changing /etc/X11/XF86Config , copy it over /etc/X11/XF86Config-4

anyway,
I'm looking for more information on that point about the usb mouse device file now.
------------------------------------
There is a separate issue of mouse configuration --how GPM uses the mouse when your in console mode. mouseconfig sets up the mouse options used by GPM in a file /etc/sysconfig/mouse
junkieclown is offline   Reply With Quote