View Single Post
Old 02-08-03, 09:33 AM   #4
LaoTzuTao
Registered User
 
Join Date: Sep 2002
Posts: 23
Send a message via AIM to LaoTzuTao
Default

Well first off I would go through and make absolutely sure NVIDIA_kernel is uninstalled, rpm -q NVIDIA_kernel to see if you have it installed anymore, and what version is installed, you might have more than one installed somehow, I'm not sure...do a search on your drive for nvidia.o and delete it anywhere it might be. Then once you've made sure there are no NVIDIA files installed...try reinstalling the NVIDIA files again. I'm not quite sure what you mean by "extracted the sources into my local directory with rpm -ivh -root /root/src then I compiled them " I've just never seen a command like that...what I did was just
'rpm --rebuild NVIDIA_kernel-1.0-4191.src.rpm'
That should go through and configure the package and create an actual normal rpm for you to install...It'll print out a few lines like a regular ./configure, so check a few lines up when its done for a line that says 'WROTE:' to see where it put the new rpm. For me with SuSE it was /usr/src/packages/RPMS/i386/ So assuming thats where it put the rpm, then do
'rpm -ivh /usr/src/packages/RPMS/i386/NVIDIA_kernel-1.0-4191.i386.rpm'
It should install fine, but print out a warning that it will taint the kernel, but that's fine. After that, do the same with the GLX package...
'rpm --rebuild NVIDIA_GLX-1.0-4191.src.rpm'
That should write it to the same directory, so next
'rpm -ivh /usr/src/packages/RPMS/i386/NVIDIA_GLX-1.0-4191.i386.rpm'
That should install fine also, it usually prints out a message like old glx files found, and it'll rename them for you, and if you ever uninstall the NVIDIA_GLX file it'll rename those old files and use them. After that, they should be installed correctly. Then you have to move on to editing your XF86Config file (should be in /etc/X11/) as the instructions say. You didn't mention doing that in your first post, It seems that might be part of the problem. I'll post the relevent parts of mine for you here...
Section "Module"
Load "freetype"
Load "extmod"
Load "type1"
Load "glx"
Load "speedo"
Load "v4l"
Load "dbe"
EndSection
Make sure you take out any 'dri' reference, and make sure 'glx' is in there

Section "Screen"
DefaultDepth 16
SubSection "Display"
Depth 16
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 32
Modes "1024x768"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection
As far as this section goes, for some reason you must set the default depth at 16 in order for 3D to be enabled. I can still set the depth to 32-bit in games and it doesn't seem to mind, but the default must be 16.

Section "Device"
BoardName "GeForce3 Ti 200"
BusID "1:0:0"
Driver "nvidia"
Identifier "Device[0]"
Option "IgnoreEDID" "true"
Option "NvAGP" "3"
Option "DigitalVibrance" "200"
Screen 0
VendorName "NVidia"
EndSection
For this section, replace 'nv' with 'nvidia' to use the new nvidia driver, and that might be all you have to do. For me...It took me forever to realize, but for some reason I needed to add the
Option "IgnoreEDID" "true"
to get X working, I have an old Envision monitor which is never listed as an option, I'm not really sure why that is, but it works for me. The NvAGP is optional as far as I know, just to play around with different AGP settings. I add the DigitalVibrance option just to add some more vibrant color. There are other options listed in the NVIDIA_GLX readme, go through that and play around with what you want, but after all that everything should work fine...I hope after all that you can get it working...but if you have any more errors or questions I'll be around to help. Good luck! - John
LaoTzuTao is offline   Reply With Quote