Thread: twinview bug ?
View Single Post
Old 02-08-03, 05:28 PM   #1
demiurg42
Registered User
 
Join Date: Feb 2003
Posts: 1
Default twinview bug ?

I've seen a couple of postings on the subj. but nobody suggesteda working solution so far.

It's interesting that I had twinview working - before upgrading to RH8 and installing latest
nvidia drivers.

The porblem : when I run X with option "Twinview" it freezes. If I run it on a second display (in parallel with my regular X session)
it reezes right away. If I boot into runlevel 3 (without X) and than run X -screen "Screen AGP TwinView" it starts and even seems to work but still freezes after I exit from X!

I thought about downgrading the driver, but it would force me to downgrade gcc since the older driver was compiled with gcc 2...


Any suggestions ?

My configuration :

nVidia Corporation NV11 [GeForce2 MX] (rev b2)
driver 1.0 revision 4191
2.4.20

XFree86-4 :



Section "Device"
Identifier "NV AGP TwinView"
VendorName "nvidia"
Driver "nvidia"
# update this with the PCI id of your card. Consult the output
# of the 'lspci' command.
BusID "PCI:1:0:0"

# sample twinview setup
Option "TwinView"
# be sure to replace the HorizSync and VertRefresh with correct values
# for your monitor!
Option "SecondMonitorHorizSync" "30-50"
Option "SecondMonitorVertRefresh" "60"
Option "TwinViewOrientation" "Clone"
# Option "MetaModes" "800x600,800x600;"
Option "MetaModes" "800x600,800x600 @800x600;"
# Option "MetaModes" "640x480, 640X480;"
Option "ConnectedMonitor" "crt,tv"
EndSection

Section "Screen"
Identifier "Screen AGP TwinView"
Device "NV AGP TwinView"
Monitor "MyMonitor"
DefaultColorDepth 24
Option "TVStandard" "PAL-B"
# Option "TVStandard" "NTSC-M"
Option "TVOutFormat" "COMPOSITE"
# Subsection "Display"
# Depth 8
# Virtual 800 600
# Modes "800x600" "640x400"
# EndSubsection
# Subsection "Display"
# Depth 16
# Virtual 800 600
# Modes "800x600" "640x480"
# EndSubsection
Subsection "Display"
Depth 24
Virtual 800 600
Modes "800x600" "640x480"
EndSubsection
demiurg42 is offline   Reply With Quote